Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Z68 Extreme4 Gen3 2nd VGA cards not recognised.

  1. #1
    Pat Man is offline Junior Member
    Join Date
    Nov 2012
    Location
    UK
    Posts
    3

    Angry Z68 Extreme4 Gen3 2nd VGA cards not recognised.

    Hi all, new here. I'm at a loss so thought I'd give you knowledgeable heads a go as I'm at a loss and on the verge of RMA'ing my Mobo. It's been working beautifully until I tried to add a 2nd or 3rd VGA card for CrossFiring and folding. The Mobo won't recognise any other VGA cards in any but the 1st pcie slot. I've tried 2 x HD5970's and 2 x HD5870's but the 2nd cards are not detected. All the cards work fine when placed in pcie slot 1 singularly. Here's a list of what I have done so far to resolve the issue:

    Updated bios - latest 2.30 installed
    Updated Radeon drivers - latest installed
    Re-installed all drivers
    Re-installed OS
    Re-seated all cards in all slots
    Cleared cmos
    Disabled on-board graphics in bios
    PCIE is set to primary in bios
    Extra Molex is connected to Mobo as per instructions
    Disabled Vitu
    Changed PSU
    Checked & re-checked all connections
    Banged my head against a wall vigourously

    I've noticed that the last two bios updates from ASRock are addressing this issue, so have I bought a multi vga board that will only work with 1 vga?! I would really appreciate any input or suggestions guys, thanks in advance.

    PS: I've been building PC's for years, and have never come across this issue before. Stumped.

    EDIT: Anyone got any ideas? Someone from support maybe??
    Last edited by Pat Man; 11-08-2012 at 03:35 AM. Reason: 7 hrs later.....no replies yet.

  2. #2
    parsec's Avatar
    parsec is online now Senior Member
    Join Date
    Jun 2012
    Location
    Tau Ceti
    Posts
    3,129

    Default Re: Z68 Extreme4 Gen3 2nd VGA cards not recognised.

    Did you follow the procedure for using multiple AMD video cards, as described in your boards manual?

    For example, with my ASR board, you must use PCIe slot 2 and PCIe slot 3 when using two cards in Crossfire. The DVI cable is then connected to the card in PCIe slot 2. From there you must configure Crossfire in the Catalyst Control Center.

  3. #3
    Pat Man is offline Junior Member
    Join Date
    Nov 2012
    Location
    UK
    Posts
    3

    Default Re: Z68 Extreme4 Gen3 2nd VGA cards not recognised.

    Hi there, thanks for your input.

    Yeah, followed the manual to the letter, several times. I also tried every conceivable combination just in case - still nothing in device manager, only pcie slot 1 registers a card. I think I know the motherboard manual off by heart now, been through it that many times.....lol The CrossFire option only becomes available after the cards are detected, so if they're not showing up it can't be activated.

    I'm beginning to think I've got a dud, judging by the two most recent bios updates from ASRock - it's a known problem, link below.

    Z68 Motherboard Series Manufacturing - ASRock Inc.

    But I do know that it's not a general problem, as some people have reported no problems with theirs........but it's driving me a bit mad now to be honest.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •