Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: I cant disable speedstep

  1. #1
    1a2b is offline Junior Member
    Join Date
    Jul 2013
    Location
    Turkey
    Posts
    2

    Default I cant disable speedstep

    In bios menu whether I choose disable or enable speedstep my cpu works as always speedstep enabled.In idle cpu works 1.6ghz, in usage works 3.4ghz. I disabled speedstep but it is the same. I changed windows power controls as performance but nothing happened. I want to work my cpu on 3.4ghz. How can I disable speedstep ?

    Motherboard: Asrock z77 extreme 4 (bios 2.8) I used 2.7 before I have the same problem also.
    Cpu: intel 3570k
    ram: 2x4 gb gskill 1600mhz
    graphics: sapphire 5850
    power: 650w silverstone
    OS: win7 64bit

  2. #2
    parsec's Avatar
    parsec is online now Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,028

    Default Re: I cant disable speedstep

    I agree, it seems as if Speed Step cannot be disabled by just setting it to Disabled. It also depends on the CPU's C-State settings.

    In the Advanced menu, CPU Configuration, find the C-State settings near the top of the options. Set all of these to Disabled:

    Enhanced Halt State (C1E)
    CPU C3 State Support
    CPU C6 State Support
    Package C State Support

    Of course have SpeedStep disabled too. That should work for you, I use this board with the 2.80 BIOS, same CPU, and I tested these settings.

  3. #3
    1a2b is offline Junior Member
    Join Date
    Jul 2013
    Location
    Turkey
    Posts
    2

    Default Re: I cant disable speedstep

    @parsec

    You solved my problem.Thank you for help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •