Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: ASRock 970 Extreme3 R2.0 won't post

  1. #1
    jrl
    jrl is offline Junior Member
    Join Date
    Dec 2013
    Location
    United States
    Posts
    3

    Default ASRock 970 Extreme3 R2.0 won't post

    Hello. I have a brand new 970 Extreme3 R2.0 that will not post. I have removed everything except the CPU (AMD FX6300) and still get no beeps. When I do have the VGA adapter (plain ATI Rage), nothing ever happens. It's connected to a 550W PSU. All of the case fans and CPU cooler fan start as expected. Please help!

    Memory is 2x 8GB Kingston 1600 HyperX Black. Even when I remove it I also get no errors.
    Last edited by jrl; 12-07-2013 at 02:14 PM. Reason: additional info

  2. #2
    - wardog -'s Avatar
    - wardog - is offline Spam Killer
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,114

    Default Re: ASRock 970 Extreme3 R2.0 won't post

    By chance did you neglect to connect the 8pin ATX12V connector from the PSU to the MB?
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the PSU Calculator found HERE to determine if it might be the PSU causing issues. I do(Lifetime PRO ver.) and will mention so if it is marginal for your build.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

    Mine: ASRock Z77 Extreme6, i7-3770K, 16GB F3-14900CL9D-8GBSR, Seasonic X-750 Gold, On-die HD 4000, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Hers: ASRock 990FX Extreme4, FX-4170, 16GB AE316G1601U2K, Seasonic X-650 Gold, Asus HD7770-2GD5, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Server 1: ASRock 990FX Extreme9, FX-8150, 32GB AE316G1601U2K, Seasonic X-750 Gold, IBM ServeRAID M1015, PowerColor AX5450 1GBK3-SH, Corsair H80i, Antec Spot Cool, Fractal Design XL R2
    Server 2: ASRock FM2A88X Extreme6+, A10-6800K, 16GB F3-17000CL11D-8GBXL, Seasonic SS-660XP2, Fractal Design Arc Midi R2

  3. #3
    jrl
    jrl is offline Junior Member
    Join Date
    Dec 2013
    Location
    United States
    Posts
    3

    Default Re: ASRock 970 Extreme3 R2.0 won't post

    Thank you so much. I had originally connected the 6-prong power and not the 8. At least now I'm keeping the no-memory beeps. I promise I normally check to make sure "it's plugged in".

    I'll let you know how it goes!

  4. #4
    jrl
    jrl is offline Junior Member
    Join Date
    Dec 2013
    Location
    United States
    Posts
    3

    Default Re: ASRock 970 Extreme3 R2.0 won't post

    Just to follow up, everything seems to be working fine now. Thanks for catching my dumb mistake!

    On an unrelated note, I'm sure I'm just not seeing it, but where do you update the date/time in the BIOS? I've gone through every menu in there and can't seem to find a place to update it.

    TIA!

  5. #5
    - wardog -'s Avatar
    - wardog - is offline Spam Killer
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,114

    Default Re: ASRock 970 Extreme3 R2.0 won't post

    On the "Main' page of the BIOS, Date/Time in lower right corner, click on it.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the PSU Calculator found HERE to determine if it might be the PSU causing issues. I do(Lifetime PRO ver.) and will mention so if it is marginal for your build.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

    Mine: ASRock Z77 Extreme6, i7-3770K, 16GB F3-14900CL9D-8GBSR, Seasonic X-750 Gold, On-die HD 4000, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Hers: ASRock 990FX Extreme4, FX-4170, 16GB AE316G1601U2K, Seasonic X-650 Gold, Asus HD7770-2GD5, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Server 1: ASRock 990FX Extreme9, FX-8150, 32GB AE316G1601U2K, Seasonic X-750 Gold, IBM ServeRAID M1015, PowerColor AX5450 1GBK3-SH, Corsair H80i, Antec Spot Cool, Fractal Design XL R2
    Server 2: ASRock FM2A88X Extreme6+, A10-6800K, 16GB F3-17000CL11D-8GBXL, Seasonic SS-660XP2, Fractal Design Arc Midi R2

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •