Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Z87E ITX Mini ITX Not connecting to internet

  1. #1
    otter111a is offline Junior Member
    Join Date
    Jan 2014
    Location
    Bethesda, MD
    Posts
    1

    Default Z87E ITX Mini ITX Not connecting to internet

    Hello,

    I purchased a Z87E ITX Mini ITX last night. I installed UBUNTU 12.04 as an OS. However, when I attempted to connect it through a wired connection to the internet it was unable to connect.

    I then exited from the OS and upon restarting entered into the UEFI management system. From there I attempted to connect to the internet to send a support ticket. However, I was unable to establish an internet conenct through the UEFI system. I have used the wire that I am using to connect the mother board to the router in other systems and it works fine.

    My initial thought was that the Linux OS didn't have the necessary drivers, but that should affect the UEFI system.

    Any thoughts on what this could be?

  2. #2
    parsec's Avatar
    parsec is online now Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    3,850

    Default Re: Z87E ITX Mini ITX Not connecting to internet

    Quote Originally Posted by otter111a View Post
    Hello,

    I purchased a Z87E ITX Mini ITX last night. I installed UBUNTU 12.04 as an OS. However, when I attempted to connect it through a wired connection to the internet it was unable to connect.

    I then exited from the OS and upon restarting entered into the UEFI management system. From there I attempted to connect to the internet to send a support ticket. However, I was unable to establish an internet conenct through the UEFI system. I have used the wire that I am using to connect the mother board to the router in other systems and it works fine.

    My initial thought was that the Linux OS didn't have the necessary drivers, but that should affect the UEFI system.

    Any thoughts on what this could be?
    Did you mean "shouldn't" affect the UEFI system? If so, it will affect it on a system with no driver installed whether in an OS or UEFI/BIOS. Mine did not work on a different ASR Z87 board until the Intel network driver was installed, and that on Windows. The networking Option ROM does not seem to function on its own until either the board's chipset software is installed, or the network driver.

    The Intel NIC on your board is a new model (I217V) that really works with an ethernet controller on the Z87 chipset. No native OS drivers available for it, except possibly in Win 8.1 recently.

    You could try this driver directly from Intel, but I'm not sure if it is compatible with your flavor of Linux:

    https://downloadcenter.intel.com/Det...&DownloadType=

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •