Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: 5.1 speakers don't work properly with asrock z87 pro3

  1. #1
    creeps is offline Junior Member
    Join Date
    Jan 2014
    Location
    United States
    Posts
    7

    Default 5.1 speakers don't work properly with asrock z87 pro3

    Hi guys, I have a question regarding 5.1 speakers, my spec is:

    Asrock z87 pro3 with latest update
    i7-4770k
    Windows 7 64bit
    120 GB Samsung SSD
    1 TB WD HDD
    NVidia GTX 780
    Seasonic G-750 750W PSU
    2 x 8 GB corsair vengeance pro

    Recently I just got a 5.1 speaker of Sony DAV-DZ175. All wires are plugged in on their places. When I plugged in to my pc, i didn't get all 5 speakers worked properly even though I already changed my setup to 5.1 speakers in my realtek manager and checked the "speaker fill" option, so I tested out by playing youtube from my phone and all 5 speakers worked properly.


    Magically, when I plugged in back to my pc, all 5 speakers worked well. But still, when I tried to test it from realtek audio manager, only 1 speaker that passed the test, the other 4, they did nothing. But now the problem is, sometimes the other 4 speakers can go off by itself, and turn back on by itself without me changing anything. I'm wondering what's the problem here. Do I miss something since my speaker receiver is 7.1 and I should do something else to get my 5.1 speakers work properly? Thank you.

  2. #2
    - wardog -'s Avatar
    - wardog - is offline Spam Killer
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,459

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    Seeings you can't connect these speakers directly to the PC w/o chopping off the factory attached terminators and attach 3.5mm plugs in their place .....................

    ......... what is the audio connection you're using between the PC and the dvd player?
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the PSU Calculator found HERE to determine if it might be the PSU causing issues. I do(Lifetime PRO ver.) and will mention so if it is marginal for your build.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

    ASRock Z77 Extreme6, i7-3770K, 16GB F3-14900CL9D-8GBSR, Seasonic SS-660XP2 Platinum, On-die HD 4000, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Server 1: ASRock 990FX Extreme9, FX-8150, 32GB AE316G1601U2K, Seasonic X-750 Gold, IBM ServeRAID M1015 (IT Mode), PowerColor AX5450 1GBK3-SH, Corsair H80i, Antec Spot Cool, Fractal Design XL R2
    Server 2: ASRock FM2A88X Extreme6+, A10-6800K, 16GB F3-17000CL11D-8GBXL, Seasonic X750 Gold, IBM ServeRAID M1015 (IT Mode), On-die HD 8670D, Corsair H80i, Antec Spot Cool, Fractal Design Arc Midi R2

  3. #3
    creeps is offline Junior Member
    Join Date
    Jan 2014
    Location
    United States
    Posts
    7

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    I'm just using the given 3.5mm audio jack that came when I bought the product. Do I need to use different connection cable?

  4. #4
    - wardog -'s Avatar
    - wardog - is offline Spam Killer
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,459

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    I don't see in the online manual where the DZ175 comes with any 3.5mm cable, but ..........

    So you're connecting this 3.5mm cable to the players front "Audio In" ? If so, please look and I'm guessing the 3.5mm cable is Left and Right audio only, not 5.1.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the PSU Calculator found HERE to determine if it might be the PSU causing issues. I do(Lifetime PRO ver.) and will mention so if it is marginal for your build.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

    ASRock Z77 Extreme6, i7-3770K, 16GB F3-14900CL9D-8GBSR, Seasonic SS-660XP2 Platinum, On-die HD 4000, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Server 1: ASRock 990FX Extreme9, FX-8150, 32GB AE316G1601U2K, Seasonic X-750 Gold, IBM ServeRAID M1015 (IT Mode), PowerColor AX5450 1GBK3-SH, Corsair H80i, Antec Spot Cool, Fractal Design XL R2
    Server 2: ASRock FM2A88X Extreme6+, A10-6800K, 16GB F3-17000CL11D-8GBXL, Seasonic X750 Gold, IBM ServeRAID M1015 (IT Mode), On-die HD 8670D, Corsair H80i, Antec Spot Cool, Fractal Design Arc Midi R2

  5. #5
    creeps is offline Junior Member
    Join Date
    Jan 2014
    Location
    United States
    Posts
    7

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    Hmm, I have just checked the online manual and as you said, it doesn't come with a 3.5 mm jack. Well, I got this from my friend though, maybe he lost the HDMI cable i think. Yes, I plug in to the front "Audio in" and plug the other end to the "Front Speaker" out which I guess it won't give me 5.1 sound since i only have 1 audio jack to be plugged in? How do you check if the cable is L R audio only, not 5.1? Even though it's L R only, is it supposed to be working with ipod? Because i tried with my ipod and all 5 speakers worked (even sometimes all 5 speakers work in my pc). Thanks.
    Last edited by creeps; 01-20-2014 at 06:01 AM.

  6. #6
    - wardog -'s Avatar
    - wardog - is offline Spam Killer
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,459

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    Go to "Sound Effects" in the manual to discover why you hear 5.1 from a 2-channel input.

    The 3.5mm 2ch L+R plug, it should have three distinct contact surfaces separated by two non-conductive "rings'. Left, Right, and Ground.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the PSU Calculator found HERE to determine if it might be the PSU causing issues. I do(Lifetime PRO ver.) and will mention so if it is marginal for your build.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

    ASRock Z77 Extreme6, i7-3770K, 16GB F3-14900CL9D-8GBSR, Seasonic SS-660XP2 Platinum, On-die HD 4000, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Server 1: ASRock 990FX Extreme9, FX-8150, 32GB AE316G1601U2K, Seasonic X-750 Gold, IBM ServeRAID M1015 (IT Mode), PowerColor AX5450 1GBK3-SH, Corsair H80i, Antec Spot Cool, Fractal Design XL R2
    Server 2: ASRock FM2A88X Extreme6+, A10-6800K, 16GB F3-17000CL11D-8GBXL, Seasonic X750 Gold, IBM ServeRAID M1015 (IT Mode), On-die HD 8670D, Corsair H80i, Antec Spot Cool, Fractal Design Arc Midi R2

  7. #7
    creeps is offline Junior Member
    Join Date
    Jan 2014
    Location
    United States
    Posts
    7

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    well, i think it's not a 3.5 mm audio jack though, since it only has 1 output cable. So to solve the problem, do I need a 5.1 audio jack? if so, do you know which one should i buy or you recommend? thanks

  8. #8
    - wardog -'s Avatar
    - wardog - is offline Spam Killer
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,459

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    I think at this point I'd like you to provide a pic of both ends of the cable you are using. Internet links of it will suffice.

    On this motherboard you only have 3.5mm jacks with which to connect and transfer audio out. It does not have Digital Optical SPDIF or Digital Coax connections. On the DAV-DZ175 you will only be able to connect one of them, that being Front Speakers(the green 3.5mm jack on the PC). The Front Speaker jack ONLY provides 2-channel, L+R, audio.

    The "Sound Effect" I mentioned earlier of the DAV-DZ175 can convert 2-channel audio to psuedo 5.1-channel.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the PSU Calculator found HERE to determine if it might be the PSU causing issues. I do(Lifetime PRO ver.) and will mention so if it is marginal for your build.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

    ASRock Z77 Extreme6, i7-3770K, 16GB F3-14900CL9D-8GBSR, Seasonic SS-660XP2 Platinum, On-die HD 4000, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Server 1: ASRock 990FX Extreme9, FX-8150, 32GB AE316G1601U2K, Seasonic X-750 Gold, IBM ServeRAID M1015 (IT Mode), PowerColor AX5450 1GBK3-SH, Corsair H80i, Antec Spot Cool, Fractal Design XL R2
    Server 2: ASRock FM2A88X Extreme6+, A10-6800K, 16GB F3-17000CL11D-8GBXL, Seasonic X750 Gold, IBM ServeRAID M1015 (IT Mode), On-die HD 8670D, Corsair H80i, Antec Spot Cool, Fractal Design Arc Midi R2

  9. #9
    creeps is offline Junior Member
    Join Date
    Jan 2014
    Location
    United States
    Posts
    7

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    Hmm, I see. Below is the pic of the audio jack:


  10. #10
    - wardog -'s Avatar
    - wardog - is offline Spam Killer
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,459

    Default Re: 5.1 speakers don't work properly with asrock z87 pro3

    Quote Originally Posted by creeps View Post
    Hmm, I see. Below is the pic of the audio jack:
    Quote Originally Posted by - wardog - View Post
    The 3.5mm 2ch L+R plug, it should have three distinct contact surfaces separated by two non-conductive "rings'. Left, Right, and Ground.
    That is the correct cable to connect to the green Front Speakers jack of the motherboard with, with the other end plugged into the front Audio In of the DAV.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the PSU Calculator found HERE to determine if it might be the PSU causing issues. I do(Lifetime PRO ver.) and will mention so if it is marginal for your build.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

    ASRock Z77 Extreme6, i7-3770K, 16GB F3-14900CL9D-8GBSR, Seasonic SS-660XP2 Platinum, On-die HD 4000, Corsair H80i, Antec Spot Cool, Fractal Design R4 Black Pearl w/Window
    Server 1: ASRock 990FX Extreme9, FX-8150, 32GB AE316G1601U2K, Seasonic X-750 Gold, IBM ServeRAID M1015 (IT Mode), PowerColor AX5450 1GBK3-SH, Corsair H80i, Antec Spot Cool, Fractal Design XL R2
    Server 2: ASRock FM2A88X Extreme6+, A10-6800K, 16GB F3-17000CL11D-8GBXL, Seasonic X750 Gold, IBM ServeRAID M1015 (IT Mode), On-die HD 8670D, Corsair H80i, Antec Spot Cool, Fractal Design Arc Midi R2

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •