Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Setting BIOS mode to Legacy from UEFI on 990FX Extreme3?

  1. #1
    videatoculo is offline Junior Member
    Join Date
    Feb 2014
    Location
    UK
    Posts
    2

    Question Setting BIOS mode to Legacy from UEFI on 990FX Extreme3?

    Trying to install windows 7 64bit on a OCZ RevoDrive 3, but windows cannot see the RevoDrive. Contacted OCZ Support and they say to set BIOS to Legacy mode as RevoDrive will not work in UEFI mode. However, I'm unable to find where to set this in the BIOS.


    Any Help You Can Provide Would Be Much Appreciated!

  2. #2
    parsec's Avatar
    parsec is online now Senior Member
    Join Date
    Jun 2012
    Location
    Tau Ceti
    Posts
    3,129

    Default Re: Setting BIOS mode to Legacy from UEFI on 990FX Extreme3?

    Happy to help you, but IMO OCZ support just got rid of you, since their advice is not your issue. Particularly if you aren't familiar with "UEFI Booting", and given your question you aren't, no offense. Plus that is more of a Windows 8 thing.

    First, do you have the special driver that MUST be used with a RevoDrive? IMO, that is why Windows 7 cannot see the Revo. You must select a Custom installation, and click the Load Driver option, and have the driver on a USB flash drive. After loading the driver (do NOT remove the flash drive until the Windows installation reboots) you can then see if the Revo was formatted, as you should see partitions displayed for the drive.

    About UEFI mode, while your board has UEFI firmware instead of BIOS firmware, the default BIOS settings are to run it in Legacy/BIOS mode, that is a given on all mother boards.

    To be in UEFI mode, you must enable that yourself in one of two ways: By setting Secure Boot to enabled, or setting an option called CSM to disabled. Secure Boot is in the Boot menu, and CSM might be there too. If not, it may be in Advanced/ACPI.

    So unless you enabled Secure Boot, or disabled CSM, you are not booting in UEFI mode, it's that simple. If you did not touch those options, I highly doubt they are set for UEFI booting, but check this anyway.

    One more thing... not all boards can boot from a PCI-E slot, meaning a card or device in a PCI-E slot. My two ASR boards cannot do that. Being able to boot from a PCI-E device is not common, it is the exception. If the Revo driver makes this possible, great, but if it doesn't work, it could be the board, sorry to say.

    Good luck with your Revo, they can be a pain to get working right.

  3. #3
    videatoculo is offline Junior Member
    Join Date
    Feb 2014
    Location
    UK
    Posts
    2

    Default Re: Setting BIOS mode to Legacy from UEFI on 990FX Extreme3?

    Many thanks for the reply. Your right I'm not familiar with UEFI, but you've enlightened me. OCZ got back to me and I'm now in the process of wiping and updating the Revo's Firmware with a USB boot disc, as you said would be needed. Keeping my fingers crossed!

  4. #4
    parsec's Avatar
    parsec is online now Senior Member
    Join Date
    Jun 2012
    Location
    Tau Ceti
    Posts
    3,129

    Default Re: Setting BIOS mode to Legacy from UEFI on 990FX Extreme3?

    Quote Originally Posted by videatoculo View Post
    Many thanks for the reply. Your right I'm not familiar with UEFI, but you've enlightened me. OCZ got back to me and I'm now in the process of wiping and updating the Revo's Firmware with a USB boot disc, as you said would be needed. Keeping my fingers crossed!
    Well, the firmware is one thing, that on the Revo itself, and the Driver needed during Windows installation is another thing that must be used, or it just won't work.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •