Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Asrock z87 fatal1ty killer MB errors

  1. #1
    Slam56 is offline Junior Member
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    3

    Exclamation Asrock z87 fatal1ty killer MB errors

    Hi folks, trying to build a new pc with this board, i74770, gskill ripsaw 2133 ram and radn r9 290 gfx card. Completed build and received 4 short beeps on post. This would seem to be timing error from ram I thought so removed most ram (4x4gb) checked mbcompatibilty list again and should be ok. Removed ram. And most mob connectors except power. Still getting beeps. With nothing on the board except CPU. Getting 3 long beeps continuously.
    Help! Please.where to now?

  2. #2
    parsec's Avatar
    parsec is online now Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    3,905

    Default Re: Asrock z87 fatal1ty killer MB errors

    No RAM will give you three beeps, a no memory error, how can anything work without memory? Forget that. Try two sticks in slots A2 and B2. Full model number of memory would help.

    Remove the video card and use the on-CPU video to see if the board starts up fine. Otherwise connect all power cables, 24 pin and 8 pin CPU power, although you did not mention your PSU.

  3. #3
    Slam56 is offline Junior Member
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    3

    Default Re: Asrock z87 fatal1ty killer MB errors

    Quote Originally Posted by parsec View Post
    No RAM will give you three beeps, a no memory error, how can anything work without memory? Forget that. Try two sticks in slots A2 and B2. Full model number of memory would help.

    Remove the video card and use the on-CPU video to see if the board starts up fine. Otherwise connect all power cables, 24 pin and 8 pin CPU power, although you did not mention your PSU.
    Already took out gfx board. PSU should be fine its an corsair gold power 850 I think.
    I was hoping that the board would at least get to post without ram. Will try mem only (after work tonight.)

  4. #4
    Slam56 is offline Junior Member
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    3

    Default Re: Asrock z87 fatal1ty killer MB errors

    Woops did I say.. Never mind psu is thermaltake tough power gold 850. Memory is gskill ripjaw F3-17000CL9Q-16GBZH DDR3 2133 4x4.

    O.K. Found out the principal cause of my issues. The intel CPU stock fan has its power wires wound round the top side of the fan casing. The wires were tight and had pulled into the very close fan blades causeing it to not be able to spin. This must have overloaded the cpufan connection and the board would not start. Now it does.
    Only left with one issue. Carefully reconnected everything. Testing as I went. Got to bios at last and able to start up until I put in the radeon r9 290. Board is not recognizing the gpu is there I think and now boots with 5 beeps and no monitor. Makes a boot sound though. Tried to connect to the inbuilt gpu connector while the radeon still inside connected but same result. I am guessing the. 5 beeps relates to an issue here.
    And so it goes on.
    Now pull out the radeon. Maybe update the bios may help.
    Any ideas anyone?
    Last edited by Slam56; 02-13-2014 at 09:07 PM. Reason: New solutions

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •