Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By stasio

Thread: Intel MEI Drivers for Gigabyte z68 Boards?

  1. #1
    oubadah is offline Junior Member
    Join Date
    Jan 2011
    Location
    NZ
    Posts
    40

    Default Intel MEI Drivers for Gigabyte z68 Boards?

    These MEI drivers always confuse the heck out of me. I have a ga-z68x-ud3r, and I want the latest MEI for it. I look on Intel's site and the latest is 8.0.3.1427, but it says it's for Intel 7 series chipsets, but other sites have the same MEI listed for 6 series also.

    The latest MEI drivers that is specified as being for 6 series in Intel's site is 7.1.20.1110. They say it's the 'latest', but it's from 2011.

    I was recommended 8.0.0.1351 by someone on here or another forum for my ga-z68x-ud3r, and it worked fine. So why does intel only have antiquated drivers listed for the 6 series?

    Can I use 8.0.3.1427 for my ga-z68x-ud3r?

  2. #2
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Intel MEI Drivers for Gigabyte z68 Boards?

    I agree!!! Hahaha, sorry!

    I tried to install version 8 a little while ago because Stasio suggested it to me, and it wouldn't install for me on X79, said incorrect platform or wrong hardware, ect. So I had to use version 7.

    But I have installed verson 8 on Z68, I think, so that's why up until recently I've advised others to use versin 8 as well. So I'm not sure why there are two different versions, Intel needs to stop doing this "two version driver" crap!

    I'll see if Stasio can tell us anymore about this, for now I'd say stick with what you have installed until we can find out for sure. If you want, and are a member of the Intel forum, maybe you could get some direct answers from them about this? If you do that, please ask about P67, Z68, X79, and Z77 too, and which version 7/8 should work for which boards, thanks!

  3. #3
    stasio's Avatar
    stasio is online now GIGABYTE Elite
    Join Date
    Oct 2007
    Location
    My
    Posts
    4,751

    Default Re: Intel MEI Drivers for Gigabyte z68 Boards?

    Yes,
    I have installed MEI ver.8 until I saw I got wrong reading in TouchBIOS.,so I am back to v.7.
    No any other gain with MEI v.8.
    btw,
    ASUS try to implement latest ME8 in their BIOS's for P67/Z68 (last two weeks) series and now customers have a serious problems,since they cann't flash back..

    **Official** ASUS ROG Maximus IV GENE-Z68 & Z68(Gen3) Owners Club
    Official ASUS BIOS and Program Updates - Page 275 - [H]ard|Forum
    Lsdmeasap likes this.
    GA-Z97X-SOC Force ,Core i7-4790K @ 4.9 GHz
    GA-Z87X-UD3H ,Core i7-4770K @ 4.7 GHz
    G.Skill F3-2933C12D-8GTXDG
    @ 3100 (12-15-14-35-CR1) @1.66V
    2xSSD Corsair Force GS 128 (RAID 0), WD Caviar Black SATA3 1TB HDD,
    Evga GTS 450 SC, Gigabyte Superb 720W
    XSPC RayStorm D5 EX240 (Liquid Ultra)
    NZXT Phantom 630 Ultra Tower
    Win 7 SP1 x64;Win 8.1 x64;
    Win 10 x64

  4. #4
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Intel MEI Drivers for Gigabyte z68 Boards?

    Thanks for the insight Stasio!! So, it seems we should wait and stick to 7 for now!

    Why can't they flash back, due to ME 8 in the BIOS, if so why can't they insert ME 7 instead, or flash back older BIOS itself to correct?

  5. #5
    flyfisher is offline Member
    Join Date
    Dec 2008
    Location
    South Central PA
    Posts
    190

    Default Re: Intel MEI Drivers for Gigabyte z68 Boards?

    A previous version 9.2.0.1030 of the Intel chipset drivers has an inf file named "cougME" for Management Engine Interface. It is no longer present in the latest drivers. There are no actual drivers associated with the inf file, it just configures the system like the rest of the inf drivers. Anyway, on my Z68XP-UD4, when I installed the 7 or 8 series MEI drivers I would get a yellow bang for MEI, that the device couldn't start. So you may want to try the chipset driver instead.
    Code:
    [Strings]
    INTEL="Intel"
    ;CougarPoint HECI
    PCI\VEN_8086&DEV_1C3A.DeviceDesc="Intel(R) 6 Series/C200 Series Management Engine Interface - 1C3A"
    Name:  MEI2.png
Views: 6317
Size:  105.0 KB
    Last edited by flyfisher; 03-20-2012 at 08:54 PM.
    Gigabyte Z87X-UD4
    i7 4770K
    Samsung MV-3V4G3D/US 2x4GB
    Samsung 830 256GB SSD
    Seagate 1TB x 2
    Seasonic X650
    MSI Radeon 7790
    Lian Li PC-9F
    Thermaltake Water2.0 Pro

  6. #6
    oubadah is offline Junior Member
    Join Date
    Jan 2011
    Location
    NZ
    Posts
    40

    Default Re: Intel MEI Drivers for Gigabyte z68 Boards?

    Hmmm, thanks for the replies guys.

    I actually forgot I'd posted this thread and curiosity got the better of me and I installed MEI driver version 8.0.3.1427. I guess it means 'up to 8.0.3.1427', because the actual driver it installed was 8.0.0.1262.



    I'm not sure about the firmware side of it - I haven't tried any modded BIOS, just the latest standard F7 revision for my board (Z68X-UD3R-B3). I don't know about TouchBIOS either, I just configured it using the traditional interface. I only just did a clean install of Windows, but so far no issues. Do you think I should install v7 MEI software, or stick with 8.0.0.1262 and see how it goes?. I don't use MEI, but I want to make sure it doesn't cause any boot issues like I've been having recently.

    PS. The intel INF package I installed was 9.3.0.1020 if anyone wants to know.
    Last edited by oubadah; 03-21-2012 at 03:00 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •