Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: crook PSU????




  1. #1

    Default

    hey guys! 2 days ago I installed a new Antec True Power 480w PSU and it ran well until last night when I turn on my pc and after about 5 secs she went dead. I opened up me pc and on my m/b theres a little red light that lights up when theres power going through it but that about it, nothing else powers up. I tried the test where you stick a paper clip into the power conector joining black and green conectors and she did bugger all, I then tried the same thing on 2 other older PSU's I had and they run ok so has my new PSU just died ???? sys specs below.


    XP2100+
    ABIT NF7-S
    512mb DDR 333 MHz + 512mb DDR 400 MHz
    G-Cube 9600XT (2.5ns)
    XP Pro
    assortted drives.......

    ATM i've got it running with an older 350W PSU
    64/3500+ | Gigabyte K8NS Ultra 939 | Gainy 6800 GS golden sample using 71.20 and DX 90c| 1Gb Geil PC3200 | WD 120Gb 7200rpm 8mb buffer | XP Pro + SP1 | Pioneer DVD burner dual layer | Antec 480 watt truepower wrapped in a Enermax 710B case | Dell 21" Trinitron.....etc

  2. #2
    Join Date
    Feb 2003
    Location
    Fincastle, IN, USA
    Posts
    3,776

    Default

    You probably just got a bad one, **** happens like that sometimes

  3. #3
    Join Date
    Apr 2004
    Posts
    65

    Default

    Yeah, tough luck there guy. Hope you can exchange it for one that works wherever you got it.

  4. #4

    Default

    GOD HATES ME..............


    I always have bad luck with conponants!


    last 12 months.........

    2 x ASUS A7N8X dlx's just up and died
    64/3500+ | Gigabyte K8NS Ultra 939 | Gainy 6800 GS golden sample using 71.20 and DX 90c| 1Gb Geil PC3200 | WD 120Gb 7200rpm 8mb buffer | XP Pro + SP1 | Pioneer DVD burner dual layer | Antec 480 watt truepower wrapped in a Enermax 710B case | Dell 21" Trinitron.....etc

  5. #5
    Join Date
    Nov 2003
    Location
    Minnesota, United States
    Posts
    4,543

    Default

    Maybe ASUS hates you, not God. Then again, maybe both ASUS and God hate you. :wink:
    It's just a PSU, you'll be fine. Get a new one, they aren't that expensive.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •