View Full Version : ECS K7S5A Pro Ver5 - Dud USB :-(

07-07-2003, 04:43 PM
I was quite happy with my old mobo, Version 1 of this same board. However, thru ultra heavy use I've had to replace it, and have now got the Pro.

Problem - USB devices are not recognised. For example, my Nikon camera installs as "unknown device" in Device Manager, but no removable drive shows up in Explorer.

I am using Windows XP upgrade on top of Windows 98SE. Have formatted C: and reinstalled several times, repeating the full process each time (cannot install XP directly onto bare drive, must start with 98SE each time). Have uninstalled USB drivers and reinstalled several times -

SiS 7001 PCI to USB Open Host Controller (x 2)
USB Root Hub (x 4)
VIA Rev 5 or later USB Universal Host Controller (x 2)
VIA USB Enhanced Host Controller

I do hope someone can help (I've written to ECS-UK, not holding my breath) as I shall have to RMA soon if I cannot sort this out.

Many thanks, parthena.

07-07-2003, 10:38 PM
First off, You need to get XP installed by itself, not on top of 98SE, its known tro cause a lot of problems when inmstalled that way. Second, are you sure XP has the drivers for your device? If they dont, thats why its showing p as unknown. Try plugging in a device that you know XP has the drivers for, and see if it installs.

07-08-2003, 02:23 AM
I can't afford to buy a full new XP, and as everything worked fine in my previous setup (K7S5A Version 1 + 1000MHz Athlon + Win98SE + WinXP-Pro upgrade) I'm hoping there's another solution.

I've tried loads of devices, none of them are recognised.

Sob-sob, temper-temper


Thanks so much for replying,


07-08-2003, 02:26 AM
Doesnt seem like its your mobo, causer i dont think it would even recognize the device if that was it, Maybe try Bios flash?

07-31-2003, 08:23 PM
I also have an"upgrade"version of xp pro. It installs on it's own without using any other os or keycode. Just the xp keycode that came with it.
Oh, and that board has usb 2.0
I don't know if you need any drivers for it(the usb 2.0)

08-01-2003, 03:47 AM
...for all your replies.

I did have the correct drivers for USB 2, and in the end I had to RMA the board. My retailer said they could take 10 days to replace it, so I went to a computer fair and bought the cheapest board I could find that took SD-RAM - an AS Rock.

I'm heartbroken really, was very attached to the K7S5A, and now I've got no forum to run to, and Crucial don't even list the ASRock, which I can get to work only if I use just 1x256 RAM. Never mind, it's done and it's working, and this board does take DDR-RAM, if and when I can afford it.

Windows XP was eventually installed - I'm very interested that the upgrade should install on its own and will test that out in the future.

Once again, thanks all, I'll be keeping an eye on you :blah:


08-01-2003, 04:52 AM
ASrock is some spin-off company from Asus. Asus quality at an ECS board price maybe? I know people seem to go in droves to ECS boards, but I kinda think they're pretty ****ty. Hoping that ASrock works out better for ya.