PDA

View Full Version : sound



disavowed
02-21-2002, 03:10 AM
:shoot: I tried to install a PCI aureal votrex SQ1500 sound card. The drivers loaded just fine but I still get no sound. I tried downloading the lates 4in1 drive (I already had it installed) and it still will not play any sound! Please help before I shoot my computer!!!!!!! :knife:

Bern
02-21-2002, 09:40 AM
What distro do you have installed?
Don't bother with 4 in 1 drivers as linux dosn't use them or even the bios once the kernel boots.

Mr. C
02-21-2002, 10:00 AM
I feel your pain man!
I'm new at this whole Linux game (SuSE 7.3).
Several attempts at installing an au8820 board. At one time I had sound, but at startup I would get an error message - something about priorities, and running artswrapper as root or setting guid as root??
All greek to me at this point, after stumbling around the system trying to fix it, I have ended up with no sound again. (Who was it that claimed silence is golden?)
Oh well, all is not lost - I've still got the error message to keep me company:laugh:

I think at this point I may have to resign myself to popping in my old ESS 1868 board out of my old system. YaST2 is all set to handle that for me at least.

At least that will get me sound, so I can get on with learning this whole Linux gig. In time perhaps I can become "fluent" in this OS and overcome my limitations. For my problems, I am assuming that it is me lacking and not a fault in Linux.

Sorry I had no info to offer you disavowed.
But maybe you can take some small comfort in knowing you are not alone.
I'm right here brother - I just can't hear you from there:cackle:

Bern
02-21-2002, 10:12 AM
For general sound problems when you get an error about unable to open device or set SUID you should check the ownership/permissions of /dev/dsp*, /dev/mixer*, /dev/sequencer and /dev/audio. You can make the permissions r+w for everyone (can create security issues on a network) or create a sound group and add your users to this group (more secure).
This is how it goes in slack,
Use addgroup (or groupadd depening on the distro) to add a group called sound to /etc/group

(as root excecute the following)
addgroup sound

Then open up /etc/group in a text editor, and look for the line down the bottom relating to the new group you just created. Next to the colon enter in the name of the users you want separated by commas, but not spaces

sound:*:110:user1,user2,user3

Then save and exit the file.

Execute the following commands from the CLI

chown root:sound /dev/mixer
chown root:sound /dev/audio
chown root:sound /dev/dsp
chown root.sound /dev/sequencer

chmod 660 /dev/mixer
chmod 660 /dev/audio
chmod 660 /dev/dsp
chmod 660 /dev/sequencer

Then log out of the current user you just added to the /etc/group, log back in, and assuming you have loaded the module for your sound card then the user will have access to the sound devices, and it is not a security hole.

Darthtanion
02-21-2002, 10:13 AM
According to his other multiple posts on this topic, he is using Win2k Pro.

Bern
02-21-2002, 10:20 AM
Originally posted by Darthtanion
[B]According to his other multiple posts on this topic, he is using Win2k Pro.
Hmmmmm...someone isn't looking at the forum subjects before they post then...I'd move it except there is now some info here for Mr. C and his sound problem.

Mr. C
02-21-2002, 10:29 AM
Darn, I was comforted that someone else had this problem in Linux too:laugh:

:cry:

Darthtanion
02-21-2002, 11:07 AM
Not unless it's a dual-boot setup, but none of the other posts indicated this. Sorry.

Mr. C
04-15-2002, 12:43 AM
OK - I've just about had enough of this silent treatment from Linux:cry:
My inadequacies have foiled every attempt to make this Aureal card work. I'm just about ready to throw in the towel and put the POS Ensonique ESS 1868 in here from my old machine.
I've tried compiling, setting permissions, did the CVS last night. (which all indications tell me went perfectly BTW) Still I got no sound?
I am humbled, exasperated, and amazingly enough my bullheadedness is starting to wane. (that's a real bad sign - I was always more stuborn than Windows was)

I fear I have met my match in open source:laugh:

Oldbugger
04-15-2002, 10:33 AM
Don't let it get to you......

I was determined about a couple of other things when I first started to use LInux (and like I'm a 3 week veteran now....wow)......I quickly learned that stubborness and endless persistence can really spoil the computing experience if you try and get everything right from the outset.....

I'd put the ESS card in and acknowledge that at the moment the other one doesn't work for whatever reason....maybe your fault maybe the bloody cards' fault....in any event you won't have to worry with the ESS card working....and you probably won't notice much difference anyway.....it'll also give you time to have a good look around for a solution.....that's what I found....the more time for research solved a lot of the probs.........and it eased the frustration too

Bern
04-15-2002, 10:54 AM
Have you looked at the message archives at the project home page (http://sourceforge.net/projects/aureal/)?

Mr. C
04-15-2002, 11:24 AM
Yeah, I've been browsing a good deal there at sourceforge. That quickcam driver there has my attention too.
I think the truth is simply that I'm not up to drivers yet:rolleyes:
I think soon that ESS is gonna' get inside the good comp - temporarily I hope.

It's quite possible I've got these repeated installation attempts garbaging up the system in untold ways - maybe it's time to flush the drive?

Not really frustrated, just the reality seems to be I can't do it, or the 3rd rate card is screwed. It's a MultiWave - not among the cards listed in the readme.

Most likely it is <Forrest Gump voice> I'm not a smart man. </Forrest Gump voice>

It would be nice to have MP3's for company while I'm playing............I mean learning.

Mr. C
04-18-2002, 04:19 AM
Well I dusted off that ISA slot and put in the Ensonique card.
Booted up Windows and made it ignore the existence of this sub-standard sound generating device (at least in comparison to the Aureal card it is:laugh: ).
Then booted into SuSE and my goodness, Good ol' SuSE just leapt right up to the task. Told YaST2 to configure it, no problems.

For some reason the Aureal has never even been recognized as even existing in this box o' switches?? An lspci will bring it up, but not 1 thing can I do with it?
Oh well, all that is best left to a future date to be addressed (leastways if it's me that's gotta' do the addressing, it will have to be in the future:laugh: )

But anyway WHOOHOO I got me a genuine multimedia Linux box of my very own.

Oh bless the digital deities - I can listen to stuff while I play :clap:

*dancing the "happy dance"*