PDA

View Full Version : Linux installation problem



FA-MAS
02-28-2002, 11:47 AM
I'm having a problem with the installation of my Linux machine and am asking for help. I have an computer setup that has a motherboard that is using the i440bx chipset. I've disabled the onboard IDE, and am attempting to use an add-on IDE card from Promise.

I can boot with the boot disk that I made (bare.i) and am using the color.gz root disk. I'm to the point were I need to format the hard drive. You know setup root , swap, and home partitions. But if i run the command:

fdisk /dev/hda

it says it cannot open the device. The IDE card is working, and It recognizes my drive. Could it be that Linux has it classified as something other than /dev/hda? Because it's an add-on IDE card? I've tried /dev/sda and any others that I know about. But I don't know about alot. So any help would be apreciated.

Also what is the best way to clear off a drive. I mean no linux files or partitions. Also no Windows files or DOS partitions?

Just remove the partions with fdisk under Linux?

Thanks

Bern
02-28-2002, 01:50 PM
This promise card, is it a raid card?

FA-MAS
02-28-2002, 11:26 PM
Nope, it's just an add-on IDE card that does UDMA 66. Rather than the onboard IDE that does UDMA 33.

Now I was searching on google and found a couple of pieces of information that the hard drive may be named /dev/hde. And that there was an issue with Linux detecting the onboard IDE even though it is disabled. Does that sound right?

I'm gonna try /dev/hde and see what goes on.

Tell me if the information located here (http://www.linuxdoc.org/HOWTO/mini/Ultra-DMA-5.html) seems right.

Any help would be appreciated.

Bern
03-01-2002, 11:16 AM
Try hde to hdh, one of them should be the right one.

Anonymous
03-01-2002, 11:49 AM
Ok, I got that problem resolved. I had already tried /dev/hde through dev/hdh and it just wouldn't access it.

So I did some more searching and found that the kernel that I had on the boot disk (2.2.something) didn't support the Ultra66 IDE controller. I either had to patch or use another kernel. So I looked on my Slackware CDs and there was a 4.4.5 kernel. I made that boot disk and now it allows me to access the drive under /dev/hde. I can fdisk it and everything.

But the next problem is that after I use the Slackware install to format those partitions, and move onto the install. I get CRC errors when copying from the CD. Is it possible that the Promise IDE controller doesn't reliably support ATAPI devices? I'm gonna install with the CD hooked up to the onboard IDE.

Thx for the help. Plz keep an eye here.

FA-MAS
03-01-2002, 02:49 PM
D'oh, that unregistered was me.

Ok, I got past the CRC errors. By putting the CD-ROM on the onboard IDE channel. It appears as thought the add-on IDE card didn't reliably support the CD-ROM.

Anyway I got Linux fully installed. I have LILO loaded in the root and have that partition /dev/hde1 set as bootable. and now it boots off of that hard drive. But it hangs when running LILO. it just does "LI". I can't figure out what is going on. I used the kernel off of the boot floppy. Any ideas?

Bern
03-01-2002, 03:10 PM
Lilo error messages....
LI = The first stage boot loader was able to load the second stage boot loader, but has failed to execute it. This can either be caused by a geometry mismatch or by moving /boot/boot.b without running the map installer.
From http://sdb.suse.de/sdb/en/html/kgw_lilo_errmsg.html

FA-MAS
03-01-2002, 10:55 PM
ok, so it seems that I may have installed lilo after the 1024 cylinder boundary? How do I check.

Also when partitioning the hard drive using fdisk there weren't overlaps in my partitions. And the same partitions worked on the onboard IDE. I don't believe it's a geometry issue.

I'm going to re-install lilo and see what goes on.


...or by moving /boot/boot.b without running the map installer. I know that I didn't move that. But, what is it talking about, the "map installer"? Maybe it needs to be run? But how?

Bern
03-01-2002, 11:16 PM
You need to run the "map installer" before you reboot following any change to your lilo.conf, and you do that by doing "/sbin/lilo"
Lilo should be on the MBR, the 1024 thing has to do with old versions of lilo not being able to boot a kernel that resides above cylinder 1024, all new versions of lilo don't have this problem. The latest is 22.2 (http://brun.dyndns.org/pub/linux/lilo/).

FA-MAS
03-01-2002, 11:34 PM
Ok, I'm gonna try a newer version of LILO, because the lilo.conf looks good, and I was running /sbin/lilo before rebooting if i made any changes. I didn't know that was the "map installer", lol. It's all a learning experience. At least I know how to access the floppy. I'm just gonna figure out how to expand these files so i can install. I will take care of this problem like this --> :shoot:

FA-MAS
03-05-2002, 10:15 AM
Yay, I got it. Thanks Bern. What I did was uninstall my current version of lilo (using pkgtool) and downloaded the latest version 22.2, copied it to a folder, decompressed it, and installed it.

It did alot, but it ended with "cannot ditermine what the first drive is." And it said it was a fatal error. But I checked etc/lilo.conf and it was pointing to the correct drive. I then ran sbin/lilo, and rebooted. And it booted on it's own. So I think I'll be good.

Thanks again.

Bern
03-05-2002, 10:28 AM
Your welcome FA-MAS, glad I could help :)

FA-MAS
03-05-2002, 10:34 AM
Bwhahahah, add another Linux user to the mass. I'm hooked on this OS. Just the problems I had to diagnose and overcome made it much fun. I'm looking forward to much Linux usage.

Later