View Full Version : Can a chipset do this?

06-01-2004, 03:54 AM
I have a Soyo ps4 Dragon motherboard, with a SiS 645 chipset. I have extreme difficulties burning cd's that are large in size. After several minutes, I get a nag message that the burn failed. Basically, after the lead-in track, there appears to be no hard drive activity.
The processor is an Intel 1.6 gig, with 256 of ddram. The burner is a Yamahacrw2200ez. Could a faulty chipset cause this? Both the cdrom and burner will burn a cd (with no errors, and using the same file) in a slower, and older pc. I tried to tackle this problem a few months ago, but basically gave up. I tried this morning to burn a video cd and it happened again. Any ideas? Small video games (ones will basic graphics) will burn fine. So will mp3's. This is driving me insane. Help.........lol

06-01-2004, 04:17 AM
First guess is that either the chipset drivers are not all installed or DMA is not enabled for you ide chanels (look in device manager).

06-01-2004, 05:25 AM
The first time I troubleshot this issue, I checked the BIOS and it showed all channels as Ultra DMA for auto configuration.
Using your suggestion with device manager, this is what I found:
Secondary IDE Device "0" Transfer mode PIO only
Device "1" Ultra DMA mode 2

The thing I am unsure of is that the burner shows up as the Secondary Slave in the bios. Would this correlated to device"0", or device "1" ?

Thanks for the reply.

06-01-2004, 07:00 AM
Device 0 is the primary (master) on an ide channel, device 1 is the secondary (slave). Is device 0 the hard drive? It is best to have the hard drive and burner on different channels, preferably with both set as master (primary). That way they are not competing with each other so much for system recources.

06-01-2004, 08:46 AM
I have two hard drives on the primary IDE and a cdrom and burner on my secondary. I configured them this way to avoid conflicts. The burner is set to slave, as recommended by the owners manual.
Based on what you said, my cdrom was showing as PIO, so my problem lies elsewhere.
I decided to try and burn a video cd of a star trek episode. It has been trying to burn now for an hour and a half. The progress remains at 5%. The write buffer is at 98%, but very little hard drive activity is showing. Even if the burner cannot communicate with the hard drive, I am unsure why it doesnt dump the buffer? Also, in times past, I would either get a NERO error message that the write failed, or my pc would simply lock up and require rebooting. Since I went ahead and changed the PIO to Ultra DMA, neither one of those issues has arose, but it doesn't seem to be burning either. I have never attempted a VCD burn before, but I would assume I should have seen some progress in over an hour and a half?

06-01-2004, 02:35 PM
I've seen instructions with cheap cd burners to set them up as slaves too. That is just to make it simple for noobs. There are times when a dvd drive demands to be master and you have to do that. But with a cd drive and a burner, the burner should be master. A burner isn't going to work worth a damn if it won't set up with DMA enabled. PIO is pretty low on the totum pole for commanding acess to system resources, especially ram. My guess is that some other app/process has laid prior claim to the secondary channel and Nero is not getting any access.

06-01-2004, 07:48 PM
I always set a burner to be the master as a burner will need to control the IDE channel (which it can't do from the slave postion) to get the job done properly.

06-02-2004, 06:57 AM
I was pretty thorough the first time I did this troubleshooting, and I believe I did try that, but I will certainly try it again. The individual components work in another pc, so I think I am alright there. A co-worker suggested I check my swap file. He was thinking that mabye a memory shortage was halting the burn process. Also, I noticed that NERO does not dump the buffer contents, so the whole burn operation must be locking up. Sound plausuble?

06-03-2004, 09:22 AM
Found the swap file set to 360k. I dunno how it got that way, but I set it to allow XP to allocate whatever it needs. I have 256k of onboard memory, so I would think that an additional 360k would have sufficed. I am attempting another burn, I will post the results. Thanks for the replies.

06-03-2004, 09:26 AM
256k? 256mb maybe......And if you don't get DMA working, you will continue to have problems burning large files.

06-03-2004, 11:44 AM
I stand corrected. 256MB.
Ultra DMA is showing as the transfer method on all devices. The burner is now set as master. I have a dual boot and tried to burn the VCD with Windows ME. The encoding process did fine, but when the burn got to about 75% complete, my system shut down as it does when the processor overheats. Did this exact same thing twice. I am in the process of trying it again with XP, but the first attempt yielded a nag message about the disk being "non writable". I am using Memorex CD-RW.
I will keep at it, but it has really been kicking my behind. Thanks for hanging in there with me....:)

06-03-2004, 06:12 PM
I can't remember ever seeing cd burning causing an over heat. You could monitor temps while burning. I have often seen drivers cause a spontaneous reboot, particularly audio and video drivers. Also try burning a regular cdr, and try "simulated" burning. Try a burn at 8X speed. Any firmware upgrades for your burner?

06-04-2004, 06:36 AM
Dust had collected on my heat sink and fan. I am not sure if that was the problem, but it has shutdown before on thermal protection. Also, I think the one nag message was due to a bad disk.
I was able to encode and burn the VCD last night, and it played in my DVD player..:) Hopefully, this is progress.
I am not quite ready to celebrate yet, because this problem comes and goes. I have been able to burn fine for a week, only to have it re-occur a week later. I am going to try it again later. I will post the results. Thanks again for hanging in there with me.....:)

06-05-2004, 10:08 PM
I have now been able to burn TWO Vide CD's without a problem. I thought the last one was going to give me the old problem (cause it hung at 5% burn, which is the end of the lead-in track) but it kicked in and finished just fine. I will continue to watch it though. Thanks again.

06-05-2004, 10:47 PM
Yeah, if you had a dust buildup on your heatsink and removing it fixed your problems, your CPU was likely overheating while preparing to burn, when its getting heavy usage. Than when it didn't cool down in time, even though the CPU isn't heavily used while actually burning the CD, it shut down due to the thermal protection.

06-06-2004, 05:47 AM
I believe you are right, but it has refused to burn before when there was no overheating issue.
Apparantly, the advice I got from BJ (about DMA) must have helped, because I have had no issues since then. TRhe DMA channel was set wrong on the CDRom, not the burner, but the problem has not resurfaced. I guess it is one of those things that make you go "Hmmmmmmmmmmmm".