PDA

View Full Version : Bern...need some help



Oldbugger
03-27-2002, 05:13 PM
I installed the 2 tar files for the NVidia vid cards and got NO errors on install......however when I reboot the system it won't go into X unless I interupt the automatic boot sequence and go thru fail-safe load......however, when I look at the x86config.log file all was loaded without error.....it just seems that X needs a kick up the but or something.........all other indications are that the NVidia drivers are loaded OK (even the splash screen just prior to X....maybe thats the problem????)....other than this irritating little ****full thing everything else is running fine.

Without reinstalling (and losing the NV drivers) how do I get X to come up on boot again?????

[Oldbugger with furrowed brow]

Bern
03-28-2002, 11:14 AM
Edit /etc/inittab and change the default run level to 5 for a GUI login. I prefer to boot to 3 (text login) and do "startx", that way if something goes wrong with X you can use the shell to fix it.

Oldbugger
03-28-2002, 06:02 PM
Thanx

Bern
03-28-2002, 06:50 PM
Your welcome :)

Frost
03-29-2002, 09:23 AM
Hey Oldbugger and Bern! I downloaded the 2 sets of nVIDIA drivers for Mandrake from the nVIDIA web site. They must both be used, Oldbugger. Once they are installed, did you go to the place that really installs the drivers?? Know what I mean, Bern? *S* You have them on your sistem, but it's that RpmDrake progarm that gives you 3 windows, and you choose "flat" on the left window and then go and look for that program that you "Put" on the system, and click on it and it moves to screen number "2". after you get all the items you want to "install" then hit the install button and they '''install'''. Am I right Bern?

By the way, Im in here from Mandrake 8.1 off my 3 OS boot system using www.v-com.com program called System Commander 7.0. I boot into either Windows XP, Windows ME, or Linux Mandrake. All work perfectly. I know.. Windows ME, but it does have just a few programs on it that seem to do a lot better in ME than on XP, like ICQ and my Timex watch program. also the system is OC with an Athlon XP 1700 to 139 FSB X 13 multiplier.. *S* core volt at 8.0 and runs at 38C. Not bad huh?? That's 1807 MHz.. *S*

I went to a site for the X-Windows and they have a download for the newer X-Window thingy. I don't think I got it all though. Oldbugger and Bern, I did notice in the updated Xwindow in the readme that it has increased support for nvidia drivers. Thought I'd mention that.

Met this cute gal at a wine tasting yesterday from Tweedhead AU. She's studying viticulture at the Michigan State University in Lansing Mich. Says to say hi to y'all! She's a real looker!! Supposed to ask ya if ya ever heard of the Meter maids in Surfer Paradise??

Cheers!

Bern
03-29-2002, 09:33 AM
Originally posted by Frost
[B]Hey Oldbugger and Bern! I downloaded the 2 sets of nVIDIA drivers for Mandrake from the nVIDIA web site. They must both be used, Oldbugger. Once they are installed, did you go to the place that really installs the drivers?? Know what I mean, Bern? *S* You have them on your sistem, but it's that RpmDrake progarm that gives you 3 windows, and you choose "flat" on the left window and then go and look for that program that you "Put" on the system, and click on it and it moves to screen number "2". after you get all the items you want to "install" then hit the install button and they '''install'''. Am I right Bern?
Yes, but nvidia recomend you stop X before installing the driver, even the rpm ones.

[B]
By the way, Im in here from Mandrake 8.1 off my 3 OS boot system using www.v-com.com program called System Commander 7.0. I boot into either Windows XP, Windows ME, or Linux Mandrake. All work perfectly. I know.. Windows ME, but it does have just a few programs on it that seem to do a lot better in ME than on XP, like ICQ and my Timex watch program. also the system is OC with an Athlon XP 1700 to 139 FSB X 13 multiplier.. *S* core volt at 8.0 and runs at 38C. Not bad huh?? That's 1807 MHz.. *S*
w00t!

[B]
I went to a site for the X-Windows and they have a download for the newer X-Window thingy. I don't think I got it all though. Oldbugger and Bern, I did notice in the updated Xwindow in the readme that it has increased support for nvidia drivers. Thought I'd mention that.
The best way to upgrade X on mandrake is to install the 4.2 rpm's from cooker.

[B]
Met this cute gal at a wine tasting yesterday from Tweedhead AU. She's studying viticulture at the Michigan State University in Lansing Mich. Says to say hi to y'all! She's a real looker!! Supposed to ask ya if ya ever heard of the Meter maids in Surfer Paradise??

Cheers!
......mmmm....meter maids.......:crazy:

Oldbugger
03-29-2002, 11:00 AM
And there is no rpm yet for 8.2...I used the tar files and still couldn't get it going....I checked all the pointers and symlinks I could but I think X was still looking at the old drivers cause there was no additional functionality ......will wait till they release rpm for 8.2.

This morning I played around with Lycoris and RH7.1 again just to compare......yeah many installs later and I am convinced that MDK 8.2 is about the best I've found so far.... I'm going to give RH7.2 a run next week....and there is a NVIDIA rpm for that...

Bern
03-29-2002, 11:14 AM
Post a copy of /var/log/XFree86.0.log after a failed startx with the nvidia driver for me to look at, and any error messages you get when installing.

Oldbugger
03-29-2002, 03:33 PM
I tried it all as "root" and there were NO error messages at all on install. I can't get "startx" to work manually...it needs a password....none I put in work........the only symptom is that when it tries to go into X at boot it just drops back to the command line....I can use the command line for very elementary stuff but not x at all now after I tried everything again.......by the way I DID "make installs" outside of X.....and the logs show NOTHING abnormal.....I do think there is some old symlinks hanging around or something despite me following all the leads in the NV doco (all 36 pages of it)....

The other funny thing I noticed is that when I installed Star Office (official) the install said it placed entries in the KDE menu.....not true....it looks like there may be some kind of lock on some of the X system files......this is consistent with the password on "startx" etc

Anyway where all this is leading is that I can't run the stuff again cause I just reinstalled it all (clean wipe of the hdd)......I'll wait till RH 7.2 turns up and try the rpms on the NV site.

Thanks for all the help Bern.....by the way have you tried the 8.2 version????

By the way, I'm havin a ball with this stuff and these probs are really minor....I'm well and truly hooked and won't under any circumstance go back to the dark side....hehe:D :D :D

Bern
03-29-2002, 03:51 PM
I only use slackware on my comp.....last drake I used was 8.0 when it first came out.

Oldbugger
04-02-2002, 07:08 PM
Tried RH7.2 this evening.....MDK 8.2 is still the best so far.....

Oldbugger
04-03-2002, 06:57 PM
Got the NVIDIA driver to work successfully with MDK 8.2 ... the secret was to compile the Kernel first then install the drivers........thanx to some fella on the forums at Nvidia who had exactly my setup....well almost........ haaaaaa....

Bern
04-03-2002, 09:26 PM
w00h00!

Oldbugger
04-04-2002, 07:13 AM
As long as I select the recompiled kernel during the boot, all works well. I would like to run "make xconfig" to clean it all up but I don't really need to...the xconfig log file is a pleasure to behold when you see all the new Nvidia stuff being loaded without error....and the really important thing (hardly)......the gl screensavers work...tada......

Bern
04-04-2002, 08:11 AM
Have you had a go at tuxracer yet?

Oldbugger
04-06-2002, 05:37 PM
yeah....if you are really competitive you can get really hooked.....My granddorta had a go and got the giggles whenever she went on the rocks....I told her she was scraping all the fur off the little penguin....I can't get the hang of TRON cause I cant find the keys to control the bike...look interesting though....Simcity3000 is good though....if a little mundane

Bern
04-07-2002, 02:08 PM
Try the arrow keys.