PDA

View Full Version : CVS help required.



FA-MAS
04-30-2002, 10:42 AM
I'm installing XFree86, I've gotten it installed just fine. Now I need to configure it for my video card (Voodoo 5). But it won't let me do so untill I get the Glide libraries installed. I know how to do this, but it's through CVS. And I'm having a problem with connecting. Here's what I get.

[email protected]:~# cvs -d:pserver:[email protected]:/cvsroot/glide login
Logging in to :pserver:[email protected]:2401/cvsroot/glide

CVS password:
cvs login: failed to open /root/.cvspass for reading: No such file or directory
cvs [login aborted]: fatal error: exiting

Anyone have any Ideas on how I can get around this, or am I doing this right?

edit: I checked the box that says "Disable Smilies in This Post " and it worked. Thanks Bahamut.

Thanks

Bern
04-30-2002, 01:14 PM
I always do cvs as a user, I do everything as a user, the only thing I do as root is "make install". You don't need to be root to download, configure or compile code, you don't even have to do it in /uer/src, I do it all in /home/bern/tmp and su to root for the install.

Bahamut Zer0
04-30-2002, 02:12 PM
When you post a message, you can disable smilies by clicking the (wait for it)
"Disable smilies in this post" option. (above the send button)
:)

FA-MAS
04-30-2002, 11:12 PM
I was logged in as root, would it make a difference with the error I am getting? Also I have a normal user. I'm using his home direcotry. /home/greyfox. I could try logging in as that user though. Do you think it's trying tor ead this file /root/.cvspass because I'm logged in as root?

FA-MAS
05-01-2002, 12:12 AM
i did some more searching and found that this may be a bug with the cvs client. I see posts that there are other people having the same issue. it seems to be resolved by running the command.

touch /root/.cvspass

I'm gonna try that later

FA-MAS
05-01-2002, 01:23 PM
Ok, I did the command "touch /root/.cvspass" and it allowed me to access what I needed, I'm working on installing those Glide Libraries. But I have another question. The question is, does X come with some type of window manager? or should I be able to "startx" and have some type of desktop without installing KDE or Gnome?

Bern
05-01-2002, 01:45 PM
X has a very basic interface on its own and you'll need some sort of desktop to do anything.

FA-MAS
05-01-2002, 11:17 PM
So without KDE or Gnome installed when I "startx" it should give me something other than a black screen right?

Bern
05-02-2002, 12:36 AM
Yeah, you'll get a grey screen with black dots and an X for the pointer.

FA-MAS
05-02-2002, 11:04 AM
Ok here's the real problem I'm having. I got X installed just fine.
Now I'm trying to run "XFree86 -configure" it tells me this:

>>>>> Could not load the shared library file for Glide: "libglide2x.so"!

You need to have Glide installed to run the glide driver for XFree86.
Also, you need to tell XFree86 where the libglide2x.so file is placed
by making a soft link in the /usr/X11R6/lib/modules directory that points
to the libglide2x.so file. For example (if your libglide2x.so file is in
/usr/lib):

# ln -s /usr/lib/libglide2x.so /usr/X11R6/lib/modules

Now I assume that I need to install the glide libraries, because this doesn't exist on my system. But I can't find glide in a format I can use. All I find are stupid rpms. I don't know what to do. You think I shoud ditch this Voodoo 5 and get a Nvidia card. MAybe it would be easier or better to install. Definetly more driver support currently.

Bern
05-02-2002, 11:22 AM
Get a geforce, the nvidia linux drivers are up to the same standard as the windoze ones, get the .tar.gz format and it's a good idea to print out the nvidia readme, it has excellent install/config instructions. Also I have a script that I can send you for checking a nvidia install.

FA-MAS
05-03-2002, 03:54 AM
Hold the phone just a minute . . . Did you realize that everything I need is on the Slackware Extras CD? It's got the Glide Libraries for 2 and 3 in tar.gz format and also packages for the card itself. I'm gonna try that when I get home.

Later

Bern
05-04-2002, 05:52 AM
Ah, yes, I forgot about the 3dfx directory on the extra cd. I've never even looked in it before you remined me about it :eek:
I'll have to remember about it in case I come across someone else with obsolete video equipment :D

FA-MAS
05-05-2002, 01:10 PM
lol, ok, I got the glide libraries installed. Now when I run "XFree86 -configure", I get beyond that initial problem, but it returns me this message then halts.

(WW) ****INVALID MEM ALLOCATION**** b: 0xf8000000 e: 0xffffffff correcting
(EE) Cannot find a replacement memory range
(WW) ****INVALID MEM ALLOCATION**** b: 0xf8000000 e: 0xffffffff correcting
(EE) Cannot find a replacement memory range
(WW) ****INVALID IO ALLOCATION**** b: 0xfffffe00 e: 0xfffffeff correcting
(EE) TDFX(1): Cannot read V_BIOS

Got any ideas?

Bern
05-05-2002, 03:13 PM
Try "xf86config".

FA-MAS
06-02-2002, 10:36 AM
when I run XFree86 -configure, I can get to the point where I choose my card, I don't see the Voodoo 5 on the list. I know this card is supposed to use the tdfx module, but it doesn't show in the list.

Bern
06-02-2002, 10:53 AM
Try using "xf86config" instead of "XFree86 -configure".

FA-MAS
08-12-2002, 12:46 AM
Ok, I'm back at it again. What I've done is bought a GF4 Ti4200 for my main machine. I'm putting my GF2 Pro in my Linux box. I'm also gonna re-install Slackware, I'm going 8.1. So I'll install X along with it, see if i can get it with the generic nv driver, then install Nvidia's. Wish me luck.

Later

FA-MAS
08-17-2002, 09:45 AM
w00t! I just got my GF2 Pro in my Linux box, didn't install 8.1 though. And ran XFree86 -configure, it set it up automatically. And X is working wonderfully with KDE.

Later