View Full Version : X38-DQ6 firewire problems

10-17-2007, 04:11 AM
I have the x38-dq6 with the F4 bios and i get a Code 10 (this device cannot start) error in Vista Device manager. Here is a list of troubleshooting steps i have done so far

1. flash to F5f and F5g beta bios....no go
2. install xp pro...no go
3. go back to F4 bios and cleared the cmos, removed the cmos battery, wait 10 min, re-insert battery...no go
4. replaced the motherboard...got another one from NCIX....no go
5. allowed Vista to search for new driver....i reports the most up to date driver is already installed

I am convinced that this first production X38-DQ6 rev 1.0 has an issue with the firewire controller

Any suggestions, aside from getting ride of this "motherboard" and going with Asus.

I know that my external drive works...it has no problems on my nForece 4 board

GIGABYTE - Janus Yeh
10-17-2007, 08:58 AM
What is your system include?

10-17-2007, 09:29 AM
These are my specs

Q6600 G0 running at stock 2.4 (266 x 9)
4 gb of ddr2-667 Samsung ram (4 x 1GB) at 5-5-5-15 at 1.8V
Nvidia 8800 GTS 640
WD 320 SATA x 2
Pioneer A212 SATA DVD/RW x 2
Seasonic 550 W power supply
Vista Business

Please let me know what to try

Vista Device manager picks up the Texas instruments firewire controller, but says Device cannot start (code 10)

Trying to update the driver, Vista says that the latest drivers are already installed


GIGABYTE - Janus Yeh
10-17-2007, 09:35 AM
Can you try just use 2 ram?

10-17-2007, 09:46 AM
OK, i just powered down, removed the ram in slots 1,3 and rebooted...same problem Code 10 under the firewire entry

Tried ram in slots 2, 4 and the exact same message

This is getting very frustrating...as i need to access the files on the external firewire harddirve


GIGABYTE - Janus Yeh
10-17-2007, 10:05 AM
I guess you can use the external firewire harddirve in other pc well.

what is the firewire harddirve?

10-17-2007, 06:46 PM
Does this answer solve my problem

I bought this "top of the line" motherboard from Gigabyte, and now you tell me to use another computer, because you cannot solve my problem

Is this what to expect from Gigabyte

The firewire hdd is a Lacie 750 GB


GIGABYTE - Janus Yeh
10-18-2007, 10:22 AM
Dear Kevin

Sorry made you misunderstanding. I was mean your firewire hdd might can work correct in other MB, so you think X38-DQ6 have some problem.Than I just want to know what is the firewire hdd sothat I can find the problem out.

Yes Lacie 750 GB, you mean this one?

I Will try to find the problem.

10-19-2007, 01:37 AM
Sorry for jumping conclusions

Yes this is indeed the firewire harddrive, and it works without any problems on the older ASUS nForce4 motherboard...the gigabyte gives me the firewire code 10 error in the device manager

any thoughts


GIGABYTE - Janus Yeh
10-23-2007, 10:30 AM
Hi kali

I think you already enable your IEEE 1394 function in BIOS.
And install driver correct.

I find some information for you. can you try it?

And I get F5i BIOS, If you want to try it please mail me

[email protected]

Thank you.


10-30-2007, 07:53 AM
I sent the first board back and recieved another, and now it works...so the problem had to do with the first board



10-31-2007, 01:40 AM
I just RMAed the old board, and the new one works fine