PDA

View Full Version : multispeaker sound with PowerDVD???



krayzkrok
07-08-2002, 04:14 PM
I currently have a pair of crappy PCWorks 4.1 speakers. They cost $150 and they sound like it too. :) However, until I get something better they will have to do.

I have an older SBLive! Platinum (not 5.1) which outputs 4.1 sound to the speakers in games just fine. However, in PowerDVD XP (version 4.0) I can't select a multi-speaker output for viewing DVDs. PowerDVD does have this function, but it's listed as "optional" for those with 4.1 sound cards... um, like mine. Why no worky?! :( Is it the driver, the software, or what?

Any ideas?

krayz

Mr.Tweak
07-08-2002, 04:16 PM
Do you have a registered version or not? It may be a feature reserved for registered users, ie. people who pay for the program, not just the trial.

krayzkrok
07-08-2002, 04:21 PM
I have an OEM version. It doesn't say anywhere that it's 2 speaker only (which the last version that came with my Hercules card did). I'd gladly pay for an upgrade if I knew this was the cause of the problem.

krayz

Mr.Tweak
07-08-2002, 04:25 PM
It could well be the case.

Beefy
07-08-2002, 10:11 PM
not sure if it matters, but have you set Windows to use your 4 speakers? If you right click on the speaker in the system tray, go to Adjust Audio Properties and then go to Advanced down the bottom, you can set your speaker set up..

Like I said, I don't know if this changes things though...

krayzkrok
07-09-2002, 08:26 PM
Yes, I tried that as well, but still no dice.

However, I have now solved the problem. Basically, it appears none of the three OEM versions of PowerDVD I've obtained over the years (usually with vid cards) had multispeaker output as an option.

The only way to get 4 and 6 speaker output, in my case, was to purchase one of the Audio Packs on the Cyberlink website. It cost me $29.95 US but I've now got Dolby 5.1, DTS and Prologic II, with 4 and 6 speaker support.

Frankly I think Cyberlink are deliberately misleading people - the impression given is that PowerDVD automatically comes with the ability to playback 5.1 audio. Not even the helpfile tells you that you need an Audio Pack - only a visit to the Cyberlink website, a good search through the FAQ, and some further clicking finally revealed this.

Had I not already spent money on it, I'd have been tempted to try WinDVD instead, but I have no idea what crazy scheme they use! At least PowerDVD has better image quality and now works as I assumed it would!

Thanks for your help.

krayz

:shoot: Cyberlink

brashquido
07-09-2002, 08:47 PM
The "bundled" verions of PowerDVD are able to pass digital audio through a SPDIF connection for decoding, but isn't able to decode digital audio itself. So I wouldn't call it being deliberately misleading, as it is able to pass on the digital signal for decoding to another device. They could definitely be lot clearer on the whole thing though.

aquinianako
03-01-2003, 12:26 AM
I purchased the Powerdvd 4 Deluxe version so I can take advantage of the 6 speaker decoding. My home theatre pc is using a Audigy 2 PLatinum which is then connected to a Logitech Z680 (it's a 5.1 set). My videocard, All in Wonder 9700 Pro, is connected to an HDTV set.

When I use the 6 speaker output setting on the audio portion of Powerdvd, I get audio video sync problems in about halfway through a movie. The audio will be ahead for about a second or two.

On a recent attempt with WinXP, I tried using the PCI latency patch for my VIA KT266a chipset based mobo as well as using the latest VIA 4in1 drivers. I ended up with the video driver "loop" error. Uninstalled without success so I ended up reformatting and installing Win2000 Pro for the time being.

Has anyone ran into this problem and was able to resolve it? Tips will be highly appreciated. Thanks.