View Full Version : pegas.usb

12-17-2001, 10:01 AM
Ok, before I start rambling I'll let you all in on the fact that I'm new to linux and have pretty much no idea what going on ! Be prepared for a dumb arse question ! :cackle:

I recently installed redhat 7.2 with both KDE and Gnome (still to decide which is better). Now I'm trying to figure out how to install my pegas.usb chipset based modem (aztech um9800). I've downloaded rpm's from aztech but am a little unsure how to install them, and then how to use the modem.

I think I've got the rpm's installed :?: :?: but I dunno... The hardware browser says the modem is there (listed under system devices I think) but it can't find it when I try to configure a net connection.

So, how do you install rpm drivers ? And how do you install usb devices, such as a modem. Dumb arse question I know but if you can gimme a url (that's useful) or some hints / tips I'd be most greatfull.

Thanks !

:confused: :hammer:

12-18-2001, 09:14 PM
Linux USB info,
Linux-USB project: http://www.linux-usb.org
Linux USB Guide: http://linux-usb.sourceforge.net
Linux-USB device overview (working devices and drivers): http://www.qbik.ch/usb/devices/

[edit]This particular page has information you will need : http://www.linux-usb.org/USB-guide/x332.html
And have a look at /usr/src/linux*/Documentation/usb/acm.txt, if you don't have anything in /usr/src/linux* you'll have to install the kernel src rpm's from your RedHat cd's.

12-18-2001, 10:10 PM
Right this next link seems to have some info on getting this modem going,

12-19-2001, 10:12 PM
And have a look at /usr/src/linux*/Documentation/usb/acm.txt, if you don't have anything in /usr/src/linux* you'll have to install the kernel src rpm's from your RedHat cd's.

nope nothing there. So how do I install these files ? Do I run the installation again or is there another way ? If there are only a couple of files should I just copy them myself from the cd ? If so, what are the files ?

Man I dunno squat about all this linux stuff, it's making me feel pretty stoopid ! Oh well...


12-19-2001, 10:38 PM
First of all you need to find out exactly what kernel you have now, do "uname -a" and you'll see soneting like this,
bash-2.05$ uname -a
Linux tbird 2.4.16 #2 Tue Nov 27 09:00:12 EST 2001 i686 unknown
The bold part is your kernel version,next you look on the cd(s) for kernel-source-*version*.i386.rpm where *version* matches your kernel. Install with "rpm -Ivh kernel-source-*.i386.rpm" as root and then have a look in /usr/src/linux.

12-20-2001, 09:06 AM
k, coolies. Will do.

Thanks for yr help !

ok, place bets can I get this right or wil I have to come running back ?!


12-20-2001, 10:46 AM
Originally posted by FrodgE
[B]ok, place bets can I get this right or wil I have to come running back ?!

What odds are you giving? :smokin:

12-21-2001, 12:19 AM
lol, not very good actually ! (depending from which way you look at it !)

I tried installing the kernel source as you said but it had problems with dependancies. Since I didn't really know what I was doing or where to find the rpms it needed I just went and upgraded my installation so it would install everything it needed. I think that's all ok now. :?:

The URL you listed that goes through the install process seems only to be relavent for AMR modems, however it looks like it may also compile stuff for USB as well. Dunno, no idea ! Problem is that when I try to do a rebuild as the instructions say it just comes up and says it can't find the file (which is bollocks 'cas i can see it right in front of me). Will a corrupt rpm cause this error or am I just doing something wrong ??

12-21-2001, 04:43 AM
Linux is case sensitive so if you don't type the file name exactly it will complain.
Try "rpm -rebuild slmdm-2.03-01.src.rpm"

12-21-2001, 08:20 AM
yeah I know that one but I'm pretty sure that ain't it. Even though it's case sensitive it doesn't appear to matter when changing directories ?? :?:

If I do "rpm -qlp slm..." it lists the contents and complains about the file size. If I do --rebuild, it claims it can't find the file. It's not to do with re-typing it differently 'cas I just pressed the up arrow to get the previous command then edited the rpm switch. Think the rpm file is stuffed ? It seems ok, but at the same time it doesn't !


12-21-2001, 09:32 AM
Try downloading it again. I don't have rpm on slackware so all I can do is bust the packages and look at the contents.

12-21-2001, 01:45 PM
ok, getting now...

Is the souce code for Mandrake, SuSE and Redhat different / compatible ? I notced they have 3 different source code rpms. One for mandrake, another for suse, and a 3rd for 2.4.x.

Since I'm running RH should I be using the 2.4.x or would it make no difference ?

12-21-2001, 02:00 PM
Get this one, "slmdm-2.03-01.src.rpm", it seems to be the most generic one available, you also might want to grab any redhat ones you see but leave the mandrake ones as they probably won't be compatable with a red hat kernel.

12-21-2001, 05:31 PM
Yep that's the one I've started trying to use, however the bloody thing STILL won't rebuild for me. I've got no idea what I'm doing wrong, everything looks just fine to me.

It's screen capture time ! What am I doing wrong ??? I can't pick it.

12-21-2001, 10:16 PM
I use rh71 ..
to install a rpm

rpm -ivh (filenamecasesensitive)

now if you com across active libs you can do this:

rpm -ivh -nodeps (filenamecasesensitive)

that will allow you to install the rpm even if there are dependancy issues.

now to see if you actually have it installed and where it is :

locate (filename)

in this case do not type the whole file name as it is in the rpm instead jsut use a protion of the file.. example: i just installed:

libssl.s0.0.9.6.rpm and i wanna see where it installed to i would type :

locate libssl | less

this will tell me where it is.. and what version it is..
some of your results will be really really long that is why we pipe it with less.

anyways i hope this helps..

12-21-2001, 10:32 PM
FrodgE......try doing "rpm -rebuild" with ONE dash....

12-21-2001, 10:35 PM
One dash, ok. I've only been doing two 'cas that what the instructions said ! I'll give that a go.


12-21-2001, 10:47 PM
You might be surprised....doing --rebuild is enough to throw an error because the correct syntax is -rebuild
one dash is correct, two dashes will give an error, remember, case sensitive is not just about capitals, its about matching everything.

12-21-2001, 10:48 PM
if you
# updatedb
(this will update the locate command)
# locate slmdm | less
( this will find all instances of the slmdm and show the version)

you will see weather or not you have it installed..
the file not found error is irrelivanT (I can see from ur screen shot that you DO have it) if you do not have the rpm installed.
-unfortunatly i am @ work and do not have a linux box available to check this out on i will see when i get home.

if you think that the rpm is corrupt do this (and you think you installed it):

rpm -e (filename)

if you do a locate and find that you have a earlier version of slmdm then upgrade it

rpm -Uvh (filename)

sorry if i was not clear earlier.

12-21-2001, 10:52 PM
lol, that's ok I wasn't clear either... and I didn't realise there were more posts on the next page, doh ! Oh well, now that I've realised that I've editted my prevous post so it makes more sense. No offence Bern, I ain't about to doubt ya !

Us bloody newbies are pretty painful huh ?! I'll get there eventually, I hope.


12-21-2001, 10:54 PM
hey no worries.. i am still a newb as well.. eheh i just got interested in linux when my work wanted me to learn it.. Now i cannot wait for my tribes 2 for linux to come in so i can totally switch over.@!!!!

12-21-2001, 10:57 PM
I wanna give quake 3 a go to see how it runs compared with windows. Although I think my video drivers are in need of some serrious work, tuxracer was slow and jery as (not playable).

I'll do those later, hopefully it'll be much easier !

12-21-2001, 11:04 PM
when i was play q3 wfa the switch from window to linux gave me a +15 fps.. but there is an issue when ppl join the server you get a slight lag spike for a half sec.. that is the only thing that sucks.. but have fun.. .

12-21-2001, 11:46 PM
I get about 70fps in q3a at 1024x768x32 with a GeForce 2 mx 400 and all the eye candy turned on.

12-22-2001, 01:59 AM
i think i was up to a steady 130 (maybe it was 140) with a GF2GTS

01-09-2002, 01:11 PM
AHHHHHHHHHHHHHHHH, stupid thing ! It won't work with one dash or two... now what ????

Is there another way to rebuild & install rpm files ???

01-09-2002, 01:42 PM
Try reinstalling al the rpm rpm's....rebuild should rebuild a src rpm against your system. I'd be downloading the latest version of rpm and all its related tools to see if that fixes it. Is rpm giving any error messages when you do "rpm -rebuild *.rpm"

01-09-2002, 06:59 PM
it just sits there and complains that it can't find the file (just like the screen shot). If I do other rpm commands it (from memory) doesn't complain (doesn't seem to do anything either). Is rpm a seperate program that can be re-installed ??

01-10-2002, 06:25 AM
Do 'ls -al" in /try two and post a screenie of the resault.

01-10-2002, 01:21 PM
ok, like this then ?!

Hmmm, so what is this telling us ? Also, I checked out the man page for rpm and it agrees with the other documention I've come across that says the rebuild switch requires TWO dashes. Not that it matters, neither seem to work !

01-10-2002, 01:50 PM
Yeah....two dashes might be right....its been that long since I've used an rpm system I've forgotten most of the rpm commands, still it's not working with either. I wanted to see a ls -al screenie to compare file size, permissions etc with the copy I downloaded. If you like I can email it to you, yours might be corrupted in some way.
-rw-r--r-- 1 bern users 1007121 Dec 19 01:03 slmdm-2.03-01.src.rpm

01-10-2002, 06:14 PM
well yeah we could give that a go but the file sizes are the same so.... I'll PM you anyways.

I noticed the permissions are different, could that cause the problems ? If so, what should they be and how can I change them ??

Are there other ways to do this or is it just to painful and not worth it ?

01-10-2002, 06:48 PM
I've emailed it...it might be a bit big for yahoo, if they bounce it I'll let you know.....as for your last question.....It might be worth looking into a real modem.....getting a usb modem working is as hard as a winmodem, mostly because they are winmodems.

02-03-2002, 08:06 PM
Well I'm not sure what exactly happened but goods things occured !! :clap:

I got a new hard drive so I re-installed linux. Once done I thought I'd try rebuilding that src rpm again. This time it actually found the file and attemped to compile it ! Hoorah !!! What changed ? I have no idea ! But it decided to stop pissing me off and work, kinda.

While that's all good, it did actually run into yet another problem. I might be up **** creek in a barbed wire canoe but we'll see. As it was compiling it bombed out 'cas it couldn't find "modversions.h". I'm not sure if this header file is pretty common with linux apps and therefore no big problem or if it is indeed unique to the drivers from SmartLink. :?:

Anyways here's a screendump, can you see anything obvious ????

Thanks heaps !!

:bounce: <-- I've got no idea what the hell this thing is but it looks kinda funky !

02-04-2002, 03:41 AM
Its complaining about a missing kernel header, did you install all the kernel src and kernel dev rpm's?

02-04-2002, 08:09 AM
Yep pretty sure I did ! I selected the kernel developement option during the install so unless there is something else ?? Could it be for a different version or something ?

02-04-2002, 09:48 AM
Have a look in /usr/src/linux/include/linux for the missing file. You might need to search the cd's for a kernel headers rpm.

02-07-2002, 07:02 AM
Originally posted by Unregistered
[B]Have a look in /usr/src/linux/include/linux for the missing file. You might need to search the cd's for a kernel headers rpm.

Heh.....guess who forgot to log in.....:rolleyes2

02-07-2002, 07:53 PM
Hoorah !!! At long last I've managed to compile that freakin' source code !!!

I had a look and found that I did have that header file but the directory wasn't "linux" it was "linux 2.x" (can't remember exactly what it was but it was a number). After messing around with shortcuts so it appeared as just "linux" it compiled for me ! Yay ! Now for some happy similes --> :clap: :thumb: :D :) :cheers: Ok that'll do...

So, thinking things were going along just fine I tried to install them but got an error about unresolved symbols. Ummm, what ??? :?:

Do you know what this is and how to overcome it ??


Heh.....guess who forgot to log in.....:rolleyes2
It's ok, I won't hold it against ya !

02-07-2002, 08:23 PM
Unresolved symbols....do "depmod -ae" as root and see if that helps. With the /usr/src/linux-version number thing, what I do is have a sym link from /usr/src/linux to /use/src/linux-version, rename your kernel src directory to /linux-version and then do (as root) "ln -s /usr/src/linux-version /usr/src/linux" that way you can download a new kernel, extract it to /usr/src/linux-new-version and then do "rm /usr/src/linux" to remove the old link and then do the "ln -s...etc" using /linux/new-version. What this does is point any program you're trying to compile that needs kernel headers/includes to the current kernel version you have running via the sym link.

[edit] I goofed up :)

02-08-2002, 03:51 PM
AH-HA ! So I did something vaguely intelligent without even realising ! ... which I guess means I didn't actually do anything intelligent 'cas it was an accident ! Damn technicalities :cry:

Anyways, that whole idea makes sense to me which is good. So, now I have these drivers and I tried to install them using rpm -Uvh. But (oh this is such a stupid question I know...) now what ?! The instructions on that web page don't make a lot of sense to me. Are these drivers modules ? Do I have to load them before I can use them ? How do I know if they are loaded and are working ??

One thing that has been making me curious with all of this is the source code. I've come across many versions of source code for different versions of the driver but they always seem to be specific to a particular distribution or kernel. Does the source code vary for each distrib ? Does mandrake really need it's own source ? Does the kernel version matter ?

That brings me to my last querie for the moment, will I need to re-compile the kernel for these drivers to work or will the standard one RH comes with contain everything I need ? I plan on re-compiling soon anyway but I was wondering if I'd actually need to.

Whoa, I've crapped on far too much for one post ! :eek:


02-08-2002, 04:47 PM
You'll need to load the driver module with "modprobe **module name**" and you can view loaded modules with "lsmod".