PDA

View Full Version : PCI bus gone mad!



Ron Cottee
07-18-2002, 05:16 PM
I recently purchased an MSI KT3 Ultra ARU Motherboard and am running Windows 2000, including the service packs.. XP 1900 on board.

I cannot get the PCI bus to work, including the floppy drive. Everything else works well.

I have tried installing four cards, individually, together and in different slots. These cards work in my old system, which is also running Windows 2000.

The 1st card is a TV, video capture card (LifeView, Fly3000video). When installing the driver, I get a "code 1" error message and a report saying "data is invalid".

The 2nd card is a Matrox Millenium G200 PCI video card ( I want to run a 2nd monitor). I receive the same error message as above.

The 3rd card is a firewire controller and guess what? Yup, the same message!

The 4th card, a 10/100 ethernet, installs OK!!! but I don't know if it works. At least not untill I replace my broken laptop.

Device manager reports the devices to be configured incorrectly but will not install any drivers. Always the same "code 1" error. BIOS and Device Manager both report OK for the floppy drive but I am continually prompted to insert a disk...and I have tried several.

MSI utilites from the M/B drivers disk report everything OK and indicate when a slot is in use, as do various other reporting utilities I have.

I tried removing the AGP video card (Leadtek G4 MX440), suitably modified the BIOS and booted with just the Matrox video card. The card worked in base resolution (800x600) but again was unable to install any drivers, always getting the same message mentioned earlier.

I have reformatted the hard drive and done a fresh Windows install but the problem remains.

Anyone know what a "code 1" error is? Is the motherboard faulty, is it a software problem, am I the problem?

Regards,

Ron.
:confused:

Wiggo
07-18-2002, 06:08 PM
Did you install the latest VIA 4in1 drivers as soon as the os was on and before anthing else was added? Also is the CPU's FSB being detected right (133MHz and not 100MHz so that the right AGP/PCI divider is being selected)? :?:
<center>:cheers:</center>

Ron Cottee
07-18-2002, 07:28 PM
Yes, Via drivers provided were loaded first and fsb is at 133mhz. I've gone through bios setup according to the manual and tried umpteen variations including default.

Everything reports the bus is working...except nothing does.

Pnp detects the card/s and the "invalid data" message for the driver/s suggest a software problem but fresh install's of the O/S don't help.

Wiggo
07-18-2002, 09:18 PM
Well I'm fresh out of ideas then atm. :confused:
Time for someone else to contribute then. :D
:beer: :beer: :beer:

Bahamut Zer0
07-18-2002, 09:51 PM
Tried re-setting you BIOS to defaults?
or updating to a new bios (if available) from MSI?

Ron Cottee
07-19-2002, 01:22 AM
I tried the default bios settings, which reset the fsb to 100mhz, without success. I tried replacing the floppy drive with one I know works...but alas it didn't work.
The case is an Aopen H600A so the power supply is good. The cpu runs at 43' at idle so it's not too hot. The only hot place is under my collar!!:laugh:

Ron Cottee
07-19-2002, 01:48 AM
Updating the bios is the only thing I can think of that I haven't tried which I will at next opportunity. I'm picking up a new laptop tomorrow so will be able to check if the ethernet card works.
I'm an advertising photographer and shoot allot of digital so Photoshop rules the machine. The 2nd monitor I want to run is for Photoshop's toolboxes...not a big task for the Matrox g200. I should be able to update the bios this weekend and will post the results.
There was one event I found most odd. I tried uninstalling the video capture card software using it's own uninstall program. This caused the computer to crash. Upon rebooting a Windows dialog box came up...in Chinese!!! and promptly hung, requiring a complete reinstall of Windows. Don't know that it's relevant to the problem, but it sure was weird!:cheers:

sKuLLsHoT
07-19-2002, 09:29 AM
if its win2k i would suggest the F5 trick, look around for info on disaling the HAL of your OS coz its sounds like ACPI is causing your grief

if you go into system info, and get the irq listing up in the OS, see if u have a whole bunch of stuff on one IRQ

Bahamut Zer0
07-20-2002, 12:16 AM
I cant confirm this, I sold my g200 years ago, and with it all the horrible incompatibility memories, but I do know the g200 cards dont play nice with new(ish) hardware. the powerdesk utility applet is also a real sonofa***** as well.

The best man to ask is Beefy. I believe he is stup, i mean still using a matrox card. :)

If your familiar with video bios options, try setting them to ultra-compatible mode. Youll loose performance, but should gain some stability/operability.

Ron Cottee
07-20-2002, 08:12 AM
Conflicting irq's was my first thought. The only items sharing the same irq are the AGP card and the USB enhanced host controller(irq16) and the pci to usb open host controller and the win2000 promise MB FastTrackLite Controller (irq19). The g200 doesn't get a mention. I thought the card might be too old but the same problem applies to the video capture card and a since purchased firewire card.
Interestingly, the floppy drive light is constantly on.
I've tried the ACPI function on all available bios settings.
What's the F5 trick?
Haven't had time to flash the updated bios yet...I'm in the middle of building a new studio and it's eating into my geek time! Bought a new laptop yesterday but won't get a chance to test the ethernet till tomorrow.
Really appreciate the advice guys, I can feel a solution is not far away...:cantfocus

Bahamut Zer0
07-20-2002, 06:39 PM
If the floppy drive light is always on, you prolly have the cable reversed.

A dual-headed geforce 2 MX-400 might be worth the money and ease the headaches with the buggy-as-hell g200. The g200 cant possibly be any better than it, but I dunno.....its been a while since ive used a matrox card, they are renown for their supurb 2D performance. If you really wanna be certain, the Raedon will definatly be a wise choice and will outperform them both. This is the most expensive road though. (other than the new Matrox Parhelia)

Send me your laptop and ill test its ethernet card if you want. ;)

sKuLLsHoT
07-22-2002, 09:49 AM
i just re-read your post and the error "data is invalid" rang a bell.

i had the same problem after installing my TV tuner card in windows XP

I can't remember exactly what it all entailed, but i just kept using system restore and trying variations of drivers on the newly found tv tuner until the error went away - and it took me ages to work out

so best bet on the cards is get a new VC