View Full Version : workgroup connections

08-22-2002, 06:11 PM
Hello all.

This is my first post so I hope I'm in the right place (you'll notice the 'novice' tag). I have a small itsy, bitsy problem I am hoping you could help me with.

I have a W2K machine and a W98SE connected directly nic to nic through a crossover cable. The led on each nic is lit. The W2K is also connected to the internet through a dial-up modem. I have configured both machines with an IP address and the same subnet mask. Each computer can ping the loopback address. But neither can ping each other. Ipconfig/all resolves both my ethernet adapter and PPP adapter. Each computer is part of the same workgroup "workgroup". Neither is a member of a domain. W98 can see itself. W2000 can not see itself, only "workgroup". What have I missed?

Thanx in advance.

08-22-2002, 08:26 PM
Have you given each computer an IP address?

08-22-2002, 10:21 PM
Make sure the subnet mask is the same. That should be it.

08-23-2002, 08:08 AM
Now my mother always said that if you can't say anything nice, don't say anything at all. Aw come on, not even a little bit of humour. Well maybe then you guys must have thought I was going to do these things. So I'll rephrase. "I have configured both machines with an Ip address and the same subnet mask" :D

All kidding aside. Am I to understand then that by all rights my machines should work? Got any wild ideas about why they might not?

p.s. I mean of course differnet Ip addresses. One binary number apart.

08-23-2002, 08:28 AM
Sorry... :) When you said novice we assumed the worst. There's some people on here that don't know even the basics.

Yes, you are right. Everything should be working. It's very strange that they can't ping each other. You aren't running any firewall software like Zone Alarm or anything like that?

08-23-2002, 09:04 AM
Oh that's O.K. Beefy. Thanks for the reply. I guess this must mean I'm above a white belt now and have gotten my yellow. I will wear it proudly.

I use Sygate firewall. I rebooted without it and it didn't make any difference. Still no connection. My Ip addresses are and with subnet mask I wanted room for expansion you know. Like I mentioned, ipconfig/all on the respective machines confirms these numbers and resolves them to their mac addresses. Both machines have each been hooked up previously to the internet through adsl. Does the lit LED on each nic indicate that the adapters themselves can communicate? Or not neccessarily so?

08-23-2002, 09:41 AM
The LED on the cards show that there is a complete physical connection to something. That's all really.

For your subnet, I noticed you put 250, and also that you set your network to the 10.x.x.x range. Is there any reason for this? Just for a test, try set the subnet mask to, or even, as you are only using the last octet to signify hosts. You don't really need to be in the 10.x.x.x range either. Most people for personal networks simply use the 192.168.x.x range. I'd try that ( with subnet mask on one and with same subnet mask on the other).

08-23-2002, 10:40 AM
Sorry, the 250 was just a typo. I switched the numbers to yours. Still no luck. I'm sorta guessing it might be a W2000 configuration problem since its the one that can't see itself. Of course it can still ping itself just can't see itself. But is their some service that I need that hasn't started. For instance "network connections" service is "started". And I switched "workstation" services to automatic. I have disabled netbios over Tcp/Ip. Also I have no DNS or WINS cofiguration. I figured I didn't need any of that to start. But as you can see I can't even start. Could it be the cable itself?

08-23-2002, 11:31 AM
In Windows 2000, has it got the icon in the system tray to say that a network cable has been unplugged? That's usually a telltale sign of a dodgy cable.

DNS and WINS configs aren't needed either, so don't worry about them. It's all very strange. When FA-MAS comes back we'll see if he's got anything to add.

08-23-2002, 11:40 AM
The icon in the system tray (one for my dial-up connection and one for my local area network) remains present and indicates that a connection is "enabled" whether the cable is plugged in or not. As does the network and dial-up connections page

08-23-2002, 12:05 PM
Now that is weird. Usually that little icon will tell you when you don't have a connection.

08-28-2002, 09:15 PM
Hello Beefy. Thought I'd let you know the problem turned out to be the card. Sure is small. One-third the size of my old one. I should have bought a dual port one. Now I'll have to buy another for my ADSL connection.

Thanx for your help.