PDA

View Full Version : I need help with plugging in the front USB port



gregor3000
07-28-2010, 05:32 PM
Hello I just bought a new Intel ASRock board 4COREDUAL-SATA2 R2.0.

I am running it in Ubuntu Linux and everything works ok, but i can not figure out how to connect teh front USB port pins.

Now the scetch says that two pins on complete left (up and down) are power and then there are two upper pins called P-4 and P+4. Right of these is ground and the one dummy pin.

My casing however has the follwing markings - two wires are markes as + and - and 2 wires as Port + and Port - .

So i plugged in those marked as plus and minus into USB_PWR and those marked port into P-4 and P+4. However the front USB port doesn't register. The back ones work OK. i went to BIOS and i see everything in USB section is enabled.

Could anyone tell me what could be wrong and how to connect the propperly? Should there be a 3rd wire for ground? (cause there don't seem to be any).

Pegasrock
08-03-2010, 11:44 PM
The codes that are used for the different pins can be different. For example:
USB_PWR = VCC
P-4 = D-
P+4 = D+
GND = GND

I think your should go like this:
+ > USB_PWR
Port + > P+4
Port - > P-4
- > GND

But best is to check this with the manufacturer of the chassis or the USB front panel. If you connect it the wrong way then you risk damaging hardware (motherboard or USB port or USB device). If you know for sure how to connect it, then it would be a good idea to test it on another motherboard to make sure the front panel (still) works.