PDA

View Full Version : ASROCK 330HT cannot play 1080p content



seba.olah
09-20-2010, 04:46 PM
Hello,

i cannot play 1080p content on my 330HT ion based htpc.
the config is:

CPU: Atom 330 dual core at 1.6 GHz
RAM: 2GB
GPU: nVidia ION
HDD: 320GB
video memory share: 256 MB

htpc is connected to TV trough HDMI

when i try to play 1080p mkv files directly from HDD i have frame drops, sound gasp etc.
i've installed WIN 7 Ultimate 32bit, drivers from asrock cd, K-Lite codec pack, vlc, bsplayer etc but same result with all the players and codecs.

any help is appreciated!

thank you

krille1979
10-07-2010, 05:31 AM
Same problem here, starting to wonder if it is capable of playing 1080p at all. Getting framedrops even in 720p...

servalac
10-11-2010, 03:27 AM
I have an Asrock 330HT that plays all 1080p and 720p so forget all codec packs and other players and install Media Player Classic HD. It has the codecs built in and supports DXVA which is needed to fully use the ION GPU.
Media Player Classic - Home Cinema - Video Player (http://mpc-hc.sourceforge.net/)

As an alternative and a very nice experience try: XBMC
http://xbmc.org/download/

MPC and XBMC are freeware.

Joe_Raby
10-11-2010, 10:50 AM
Windows 7 already supports DXVA in Media Player 12. You don't need anything else installed on a Win7 machine to get hardware acceleration, short of possibly a DirectShow codec for some odd format (Divx, etc.).

Probably what's happened is when you installed all of these extra codecs and players, your DXVA support got turned off.

Windows 7 supports H.264 and AAC natively, so you don't need codecs for those.

DXVA support is already turned on for WMV/VC-1, MPEG-2 (including DVD), and MPEG-4 (all types, including H.264/AVC) - you just need a WDDM video driver installed. If your video driver can do Aero, you're already good to go.

So try a reformat with just your drivers installed, and try it again.

jackmate
10-23-2010, 07:04 AM
hi all

I have the same problem. I am using 330HT and installed klite codecs and media player classic on win7. have frame drops and i can see DXVA when playing so something is wrong.

what can i check ?

thanks!!