PDA

View Full Version : Asus p6x58d-e slow USB boot



stresstool
09-11-2011, 06:19 AM
After a couple days of looking and trying different things, I give up. What BIOS options do I need to set/clear to enable the USB (both 2.0 and 3.0 ports) to boot from a thumb drive at speed. Presently, it takes nearly a minute to boot the syslinux boot code and several minutes to subsequently boot the Linux kernel. Once the kernel is running, everything runs full speed.

I downloaded and installed the Plop (http://www.plop.at/en/bootmanager.html#intro) boot code to see if that makes a difference, and yes it certainly does. With that boot code the kernel loads and starts running in just a second or two. But I can't use Plop all the time, so it would be better for my application if the BIOS did the job.

The specifics:

Asus P6X58D-E, BIOS version 0702
i7-970
12GB memory
2x240GB Kingston SSD (whew! Are these fast, period. Doubly fast when hooked to the Maxell controller! Yikes, nose bleed time)
100GB WD Caviar

Most of the USB thumb drives I have are Kingston Datatraveler. Some 4GB and some 8GB. All the dozens of thumb drives I have all boot very fast on all the Intel brand m/b's on which I use them.

Thanks in advance.

wazza300
09-11-2011, 06:40 AM
Its in the BIOS but not sure which page,to enable usb3,try enable rather than auto

Also enable Usb storage or legacy Usb

stresstool
09-12-2011, 01:42 AM
Thanks for the tip, but nope. There is only enable/disable for the USB 2.0 and 3.0 chipset. Setting legacy to auto or enable makes no difference and setting it to disable makes all USB devices invisible to the boot menu (via F8). Slow boot whether the 2.0 or 3.0 USB sockets are used.

I have a second P6X58D-E m/b I've been using since January. I have never had occasion to boot from a USB thumb drive on it, so I just tried that one too. Same result. Very very slow boot. It is less equipped, has BIOS version 0405, i7 950, 4GB and a squadron of hard drives of various sizes.

stresstool
09-12-2011, 04:07 AM
After looking around in different forums (fora?), I see a number of comments about some BIOS's default their USB to version 1.0 or 1.1 to maintain compatibility with possibly antique equipment. After a BIOS update on those (non-ASUS) motherboards, the system would boot at speed. So that might be what is happening here too. The ASUS BIOS is setting the chipset to run in 1.0 mode?

In my case, the Linux kernel and its ramdisk images total about 18 megabytes. I know the sticks consistently read at ~20MB/sec, so I was expecting it to boot the kernel in about one or maybe two seconds and indeed that is what happens when the Plop code is used to do it (it's so fast, it's hard to measure exactly with a stopwatch). Even at USB 1.0's 1.5Mbit/sec rate, it should have only taken about 1.5 minutes to read the boot images but it takes a little over 11 minutes, so I'm not sure what's going on under the hood. There must be much more to it than just that.

To be fair, the Intel and Dell motherboards typically take 15 seconds to read those 18 MB boot images but the Plop code works equally well (at ~2 seconds) on them too.

apolo74
10-08-2011, 05:41 PM
Hi,

I'm also having some USB and SSD problems with my Asus P6X58D-E (6GB of RAM). First of all, I can NOT use a USB device to boot... I need this for installing Linux, for example, and I have no idea why USB pendrives are not bein recognized at boot time.
Second, I just bought an Intel SSD 510 120GB (SATA 6Gb/s) which I have connected to one of the two SATA6G ports of the motherboard and it seems Windows7 recognizes it but I'm not sure if the disk is working as it should (full speed). What is strange for me is that inside the BIOS the disk is recognized IDE whereas my other SATA3G disks connected to the SATA3G ports are recognized as SATA... outside the BIOS (when booting up normally) it appears as SATA.
USB3 devices are recognized by Windows but not under Linux even though Ubuntu11.04 is supposed to have all the drivers for USB3. So I also wonder if this has something to do with the BIOS. Please send me your suggestions/instructions, thanks.

Boris

dJabba
10-08-2011, 05:49 PM
Might not, but might, be the problem. A lot of USB devices aint bootable, special usb sticks. Out of the 5 USB sticks i have around, the only one that is bootable is the one specific labeld as bootable when bought.
Another thing, don't use front headers. On several occasions I have had them drop out during boot so the boot would fail, where as if the onboard backside are used it boots fine.

Just a couple things as food for thought @ those who have trouble with this.

wazza300
10-09-2011, 07:48 AM
did you set to ahci mode for your ssd or hdd? this might improve things and is a must for ssd's,did you make the usb bootable? plenty free software to make a bootable usb pen drive,and format it to fat32