PDA

View Full Version : Need help using WOL (Wake on LAN)



jim31
09-24-2002, 10:21 PM
Am I mistaken, if you have a NIC card and motherboard that supports WOL, shouldn't you be able to turn on a remote PC either through the Internet or your LAN?

I guess I don't understand how this is accomplished if the PC is powered down - how does the NIC card turn on the computer?

I'm using the "Wake on LAN Magic Packet" program but I've not been able to start up my remote Windows XP Pro PC.

I have the MAC and Internet addresses set correctly, the BIOS is set to WOL, and I believe I have the network card configured correctly.

Suggestions greatly appreciated.

Jim

Andy
09-24-2002, 10:56 PM
does you nic support WOL and do you have the WOL cable?

jim31
09-24-2002, 11:26 PM
I'm using a Linksys LNE100TX NIC card with WOL support. However, these newer cards do not use a seperate cable to the motherboard.

Jim

bigjackusa
09-25-2002, 02:53 AM
Wol works by having the network card constantly powered with 5v, so it's not really off. It recieves a "magic packet" which tells it to signal the motherboard, which switches on the power supply. As I understand it, if your card and mobo are properly configured, the power light on the nic stays on when the machine is shut down. There are a couple of settings to check.

open: start, settings, network connections
right click the "local area connection", choose "properties
your adapter is listed under the "connect using:" header
click the "configure" button
click the "power management" tab
check the "allow this device to bring the computer out of standby" box

You also need to set your power options in control panel to either prompt you or go to sleep.

jim31
09-25-2002, 04:26 AM
I'm beginning to believe my problem lies in the fact that the NIC card is not powered up when the PC is off - the NIC lights are not on!

I checked your other suggestions and everything appears correct.

I will have to look over the MB again to see if I missed anything. Right now all I did was set the BIOS to "enable WOL".

Many thanks.

Jim

jim31
09-25-2002, 07:05 AM
I looked over the motherboard manual (Asus A7V266) once again and can find no reason that the NIC card is not powered up when the computer is off.

BIOS is set to enable WOL.

Jim

bigjackusa
09-25-2002, 09:38 AM
In the power options section of control panel, under the "advanced" tab, is the "when I press the power button on my computer" selection set for standby? Also the power supply in the box must be compliant to allow for WOL.

jim31
09-25-2002, 10:04 PM
I tried your latest suggestion by putting the power switch in "stand by" but still no power light on the NIC card.

I'm using a 300w PS on the motherboard.

Thanks

Jim

bigjackusa
09-26-2002, 01:35 AM
The power rating has no effect. The power supply must meet certain specs. The following link is for a specific mobo, but other than the min current spec, should gennerally apply.

http://www.supermicro.com/TECHSUPPORT/FAQs/WOL_FAQ.htm

jim31
09-26-2002, 04:18 AM
My Enlight Corp PS is rated at 25a on the +5v supply lead and 1.5a on the +5vSB (I guess that means Stand by).

I know everybody talks about the cable between the MB and NIC card but apparently newer MB's and and NIC's no longer use these cables. Linksys tells me its done through software. The configuration for that card has the following options:

APM Mode Wakeup enabled
Flow Control enabled
Link Wakeup off to on enabled
Link Wakeup on to off enabled
Magic Packet Wake Up enabled
Media Type autosense
Priority Type diabled
VLAN ID blank
Wake on LAN enabled

I've changed some settings but it does not make any difference.

Thanks again for all your suggestions.

Jim

bigjackusa
09-26-2002, 08:23 AM
You are correct that the newer hardware does not need a cable. The power and communication is done through the pci bus. One other thought I had though. I've had problems with nics before when they were not in bus-mastering slots (drivers not setting up right, plug and play issues, defaulting to 10mbps, etc,). I don't know if it can effect WOL, but you might try moving the nic to a higher slot. Also see if your mobo supplies standby power to all of the slots. I would also think that the Enlight branded psu would meet the specs.

jim31
09-27-2002, 01:40 AM
I moved the NIC card to the slot right next to the Video - no luck.

It could be a problem with this Ausu A7V266 MB. It so happens this same board will not run my AMD XP 1700+ processor at rated speed (1463) no matter what I try. It just wants to run at the "safe" speed of 1100.

I'm about ready to order another (different) board.

Jim

bigjackusa
09-27-2002, 03:16 AM
Sorry nothing worked.

firula
08-24-2006, 05:38 AM
Another freeware tool for WOL http://www.fusion-online.com.ar/products/wol/

To change the mac address under windows http://www.fusion-online.com.ar/products/macip/

It works perfectly.

tuxfreak
08-27-2006, 12:25 AM
I know everybody talks about the cable between the MB and NIC card but apparently newer MB's and and NIC's no longer use these cables. Linksys tells me its done through software.
that is only the case if both the card and the mobo are both PCI v2.2 or better. It sounds like your NIC is, but you'll have to find out if your mobo is as well. If one is not, you will need the WOL cable between the NIC and the mobo.

Be sure you are using the latest manufacturer's drivers and not the ones provided my microsoft so you have all the possible options available.

I assume you know you need special software to send the magic packet on the PC you are using to wake up the PC we're discussing. There's even online java apps, such as this one (http://www.dslreports.com/wakeup), although it doesn't look like it's been updated in a while (winipcfg is a 9x utility, ipconfig is used in nt line)