PDA

View Full Version : Xonar D2X driver not working after connecting Transformer Prime to my PC



PalZer0
04-08-2012, 04:31 PM
I connected my Transformer Prime to my PC to see how the PC software works and ever since I did that, my Xonar D2X drivers have stopped working properly with a Code 52 in Device Manager (could not verify digital signature).

I had to reboot my PC to finish installing the Transformer Prime drivers after connecting it to my PC and that's when the problem started.

Anyone got any ideas? I've tried doing a repair install already but can't think of anything else.

EDIT: Just tried an uninstall and reinstall of the Xonar D2X drivers (using the latest drivers listed on the Asus website). No joy there either.

bla.blub
05-11-2012, 09:45 PM
i got the xonar dx and iam really happy with the modified drivers:

ASUS XONAR Unified Drivers 1.60 (post periodically updated) « brainbit (http://brainbit.wordpress.com/2010/07/19/asus-xonar-unified-drivers/)



Unified Xonar driver for all Asus Xonar Cards: DG,DS, D1 ,D2, DX,D2X, HDAV,HDAV Slim, ST, STX, XENSE – Except U1,U3, EssenceOne ; this means you don’t have to wait months or years for Asus to release (the already old) new driver version for your specific Xonar model.
Fixed 5.1 stereo upmix issue, stereo sounds won’t be upmixed to 5.1,7.1 or 4.0 anymore (stereo is played in 2.0, surround is played in 5.1) -since v1.0
Updated OpenAL 2.0.4 to 2.1.0 (for everyone how uses the GX function) -since v1.0
Fixed the Rear and Center channel delays which where enabled by default are now disabled. This fixes the strange annoying reverb that people hear with 5.1 headphones. This also offers a more “responsive” 5.1 sound experience, regardless if you are using speakers or headphones. -since v1.20
Fixes and improvements through three different versions of the driver. See the table below

maybe they help you if it dosn´t help you could also try some driver clearns but i forgot which one i used for the asus soundrivers last year :/

PalZer0
05-12-2012, 07:37 PM
I ended up solving the problem by uninstalling the driver, running Driver Sweeper in Safe Mode then reinstalling the driver.

dJabba
05-12-2012, 08:30 PM
Thanks for the idea on the unified drivers .. maybe it solves my BSODs when I have my Thunderbolt card plugged in (Xonar+KillerNIC combo from CHV mainboard). Might give it a go again... cost enough to get it :)