View Full Version : Updating 4 in 1 problem

10-06-2002, 12:06 AM
I'm wondering if anyone can help me. I am trying to update to the latest 4 in 1's (the 4.43 ), but when I check in device manager the only driver that gets updated is the cpu to agp controller. The bus master ide and the cpu to pci controller remains microsoft version from 7/1/2001. I want to install these drivers manually, so I try to direct the windows installer to where my 4.43's are. Problem is that I unzipped the 4.43's to a folder in my "unzipped" folder, but it is all the files apparently are under one installer via application. How do I get the actual individual driver files out of this via installer package?

10-06-2002, 06:05 AM
Dont worry about pointing Windows to the files. Just choose to "Install the Software Automatically" and it'll search for and install the newer version.

If that doesn't work let me know (but it should).

10-07-2002, 03:12 PM
Thanks for the suggestion, but that was the first thing I tried. Doesn't work, because my drivers are still listed under device manager as the older microsoft ones. How can you open up the autoinstaller package to get out the individual drivers?

10-07-2002, 07:24 PM
Simple enough...just use Winzip. Extract the contents to an empty folder. I just tried it and it works.

Mr. C
10-07-2002, 09:42 PM
Actually, each and every driver is not necessarily updated when a new 4in1 is released. Often only 1 driver is new. Also, doesn't it only install what your system needs by default:?:


10-08-2002, 01:47 AM
Yes, that's right. If you read my FAQ you'll see which versions are the latest and how to check them.

However if your versions are not the latest for all the drivers, you can update them all by manually pointing Windows to where they're extracted (hence this thread).

And yes, while the 4-in-1s claim to install "only what is needed" I prefer ALL my system drivers to be up to date (and I've never had a problem). VIA are just taking the safe route by installing the minimal drivers by default.

10-08-2002, 04:18 AM
I have unzipped the file to a folder, but it does not unzip them as individual files, but only as a selfextracting installer. I am trying to discover how to "unpackage" the individual driver files out of the self extracting installer file so that I can then individually install drivers manually. Anyone know how to do this?

My system is ASUS A7V266E with kt266A chipset.

10-08-2002, 03:42 PM
You can unzip the .exe (the actual installer file - not the original .zip package) using Winzip...that's what I was referring to. I've tried it and it works. You can extract the full contents of the installer .exe to an empty directory and point Windows there for the individual drivers.

10-09-2002, 01:31 PM
Thanks, Persian, for the tip. I didn't know you can "unzip" again after "unzipping" the downloaded file. I did that and it worked, but before I manually install drivers, I wanted to make sure that I am doing the right thing. Right now I run Windows XP and I already installed the service pack 1. My drivers, AFTER running the autoinstall 4.43's are as follows:

Via Bus Master IDE controller Microsoft 5.1.3597.0 7/1/2001
Via CPU to PCI Bridge Microsoft 5.1.2600.0 7/1/2001
Via CPU to AGP Controller Via 7/24/2002

Looks like the CPU to AGP Controller is the updated driver, but what about the other two?

10-09-2002, 02:47 PM
The other two drivers are the default MS XP ones. Update them to the versions shown in the sticky. The last three numbers of the driver version should correspond with the driver version shown in the installation guide.

10-10-2002, 02:17 PM
Persian, I'm getting closer. I've manually pointed windows to the bia busmaster ide controller - no problem. But I cannot locate the via cpu to pci bridge driver - where is it and what does it look like? I checked every folder and file, but no luck. Can you tell me where it is in the "unzipped" batch of folders and files?

10-11-2002, 12:34 AM
I can't recall which folder it's in. Try using the "install the software automatically" option and let windows find the new driver wherever it lies. If that doesn't work and you've pointed your system to each and every folder then I'm out of ideas.

Personally when I chose the "install the software automatically" it found the newer version and installed it.

G Smith
10-15-2002, 10:52 AM
I'm having the same exact problem today.
I've gotten the Via Bus Mastering IDE Controller and the Via CPU to AGP Controller updated but I cannot get the

Via Standard CPU to PCI Bridge updated even after pointing to all the folders in the unzipped exe file. It's staying as a Microsoft driver.

Any ideas?

Well, at least I got the two updated. Now I wonder if it's safe to install My ATI Radeon VE drivers instead of running the XP native one.

10-17-2002, 09:31 AM
Yeah, I don't think that driver exists in any of the folders. I wonder where you can get it from??

10-20-2002, 02:10 AM
I've also tried burning all the files to a CD, then having it search removable media. It still didn't find the driver for the CPU to PCI bridge

10-20-2002, 02:35 AM
HAHA!:laugh: Got it
Pick "install from a list" then
Pick "Don't Search. I will choose the driver to install"
Pick Via Tech Cpu to Pci Bridge then click have disk
the cpu to pci bridge driver is in the inf\winxp folder

G Smith
10-20-2002, 02:56 AM
Geesh and I had it search there too..

It worked!!!

Thanks for letting us know!

10-20-2002, 03:15 AM
Still can't find it!:crazy: In the inf/winxp folder, I have two files listed. The first is listed as "viamach" and it states it is a security catalog file and is 10kb in size. The second is listed as "viamach" and it states it is a setup information file and is 6 kb in size.

I point specifically to these files, but still does not install. I don't think either of these files is a driver file anyway. WHAT is going on?? Please help!

G Smith
10-20-2002, 03:28 AM
After choosing to update the Via Tech standard CPU to PCI bridge I selected "have disk" I pointed it to the inf/xp directory and it installed the driver.

Like you I didn't think it was a correct file but it worked, and updated my drivers to the Via 8/01/2001 .170 version.

10-20-2002, 05:11 AM
Well, I finally was able to install SOMETHING, but not sure if it's correct. I copied the inf/winxp files to floppy, and then used the "have disk" option to point windows to the winxp folder on the floppy where this "driver" supposedly is. I installed it (after reading a message that it is not signed, blah blah blah), and then chose not to restart since I wanted to look at the properties first. Opened up properties and where it used to say "via tech cpu to pci" it now had one of those exclamation point warnings and it was now listed as "via cpu to agp" ??? Rather than restart, I "rolled back to previous driver" and now I'm back to the microsoft 7/1/2001 driver, no exclamation point, and listed as via tech cpu to pci again. I don't know what's going on, but I don't think I wanna screw up my computer, not knowing what I'm doing.

10-20-2002, 01:50 PM
Thanks for the info. I forgot about giving more details on the "Have Disk" option (and you don't need to put it on floppy). Do it from your hard drive (click the Browse button), and go to the folder suggested above by 3dboiler.

G Smith
10-20-2002, 03:41 PM
The name of the file I pointed to was ViaMach.inf.

It is located in the inf folder of the unzipped 4 in 1 exe file and the SUB folder was WINXP.

I was also asked if I wanted to update the CPU standard host to PCI or the VIA Tech CPU to PCI bridge. I chose the VIA Tech.

I had no warning about it not being signed.

10-27-2002, 10:32 AM
Got it finally! Had to point it to viamach.inf in the inf/winxp folder. The only way it would load! Geez, what a pain - you still had to use "have disk" and then choose " cpu to pci" in the menu of choices, then it said something like "you better not load this because you'll be sorry", but I ignored it and loaded it anyway. It works, but didn't notice any performance gain at all....

10-27-2002, 10:33 AM
Thanks everyone for your help! :)

G Smith
10-27-2002, 10:35 AM
Whoot.. glad you finally got things to load

10-27-2002, 11:05 PM
I'm glad that ya's finally got it sorted. :clap:

Sorry but sometimes us older hands tend to sometimes leave out little bits of info that we probably think of as .... say "so everyday" that we sometimes just plain forget them. Of course we try not to but it just sometimes happens. http://freeze.mongtastic.be/files/emoticons4u/sad/533.gif

G Smith
10-28-2002, 01:34 AM
I didn't notice any performance improvement with the CPU to PCI driver but the AGP driver made a huge difference for me.

10-28-2002, 09:07 AM
A lot of times you won't see any performance increase but a lot of ppl usually get better stability from them which is usually preferred by most. The main reason these days for so many driver updates is the infinate hardware combinations now available, a few years ago we probably only had a quarter (if that) of what's available now in choices, so that's what most drivers now are for to address the problems with certain known configurations mainly. :)

11-14-2002, 02:29 AM
An ezy 'r way to do it is under the system compatabillity tab for the 4in1 installer Check the win2000 option and it will install the other via option disabled by XP

g alan
12-12-2002, 10:58 AM
i'm glad all of you are up on this new driver stuff...here goes
az11ea motherboard with kt133a chipset, 40 gig,512,10/100 card,cnr modem, 2way sat(usb). Trying to install logitech quick cam and my machine won't accept the driver.Logitech's web site says i need 4in1 driver and a"usb filter driver". My machine has 2 backside usb ports and pins for 2 frontside ports but i haven't found a cable for the latter. I used a belkin 4 port hub in the second backside port and am running hp photosmart card reader with no problem. Any help would be great!

G Smith
12-12-2002, 10:00 PM
G Alan,

Try this VIA thread, it walks you through the newer 4 in 1's that were just released.


If logitech recommended installing new motherboard VIA chipset drivers this is the thread ya want.