View Full Version : Internet Troubles

10-08-2002, 11:52 PM
Heres the story:

I have just installed Mandrake 9.0 on my PC (I am a major n00b at Drake having only just decided to learn linux). It is installed on a secondary partition on my XP drive and is booting up perfectly.
This PC is a client on the network connecting to the internet through an XP box via a crossover cable.

I am able to ping the server and telnet to my linux box from the server but I cannot for the life of me get my linux box to connect to the internet through my XP server. I also have no clue as to what I am doing wrong. I have setup the network giving static IPs etc. BUt for some reason, it doesn't wanna connect to the net. Is this due to the fact that linux and xp are incompatable with each other or what?

BTW: Love Linux, from what I have learnt so far, it is much more powerful than windows will ever be. :thumb:

10-08-2002, 11:56 PM
Have you setup ICS or similar program on the XP box? :?:

:beer: :beer: :beer:

10-08-2002, 11:57 PM
I have no problem using the Internet when I am running this box on XP, only when I am running it on Linux.

10-09-2002, 12:00 AM
have you set a DNS server and a default gateway? (i'm not sure how much you know about networking)

10-09-2002, 12:02 AM
I've set the gateway to the servers IP address

I set the DNS server the same too

both at

10-09-2002, 12:07 AM
on the server have you set a DNS server or gateway?

10-09-2002, 12:21 AM
the server is set as a gateway

10-09-2002, 01:20 AM
ok, now back to wiggo's question: Have you setup ICS or similar program on the XP box?

10-09-2002, 06:14 PM
Well assuming that I use this PC on Windows through the gateway then ICS must be set up. Am I right?

10-09-2002, 06:29 PM
Hey Slamo how about I move this to the Network and Internet forum as a few there (FA-MAS, etc) I believe have the knowledge to fix this for ya? :?:

10-09-2002, 06:35 PM
OK, lets do that :thumb:

10-09-2002, 08:45 PM
Found the problem

On Linux I had ICS enabled and it was trying to share the connection with a box that didn't exist. I just disabled that and it works perfectly now.

Thanks anyway guys, it was my stupidity.

10-09-2002, 09:03 PM
Yes now that would sure fix it. :cackle:

:beer: :beer: :beer:

10-10-2002, 09:26 PM
grrrrr...............now its not working again