View Full Version : P5QD Turbo - boot delay AHCI Mode

03-23-2013, 04:45 AM
Hello there!

Recently I've purchased the P5QD-Turbo and after a few days it began to show some strange behaviour when booting. I did a fresh install of Windows 7 with AHCI enabled after installing the board to my PC and everything was fine for 2 or 3 days.

Then I installed the corresponding Intel Matrix Storage driver, after that the PC didn't boot and just stand still when the Win 7 bootlogo animation is done without any HDD activity or anything. Not a real freeze since the bootlogo animation is going on, I mean the fading of the colored parts and the numlock key is still working. Same happens when booting into safe mode. Went back to the MS AHCI driver through system restore and since then the bootup stops at the exact same point but continues to load windows after about 50 sec. Now the strange thing is that this happens also with a complete reinstallation of Win 7, without any further third party drivers installed. It doesn't matter if chipset drivers or anything is installed afterwards.

If I change to IDE-Mode everything is fine and the PC is booting up like it should do, takes about 50 seconds to get into Windows, in AHCI mode it takes close to 2 minutes caused by the delay.
With Windows 8 installed the delay is still there, but only for about 35 seconds. If I install the Intel AHCI driver same as before, PC standing still at the bootlogo.
If I change to RAID mode to get into the RAID Rom settings at startup (ctrl-I) it stops right there and nothing happens even after waiting 10-15 minutes, though I dont't want to configure a Raid array I can't even access the Utility.

TL;DR version:

- IDE mode booting fine, takes about 50 seconds till desktop
- AHCI mode using 'msahci.sys' takes about 1 min 45 sec till desktop.
- AHCI mode using 'iastor.sys' takes forever, Windows doesn't boot any further.
- Can't enter Intel Raid Rom Utility at all.

What I've tried so far for troubleshooting (without success):

- Reinstalled Windows 7, fresh installation no upgrade
- Tried Installing Windows 8
- Tried 3 different HDDs for OS Installation, with different SATA Ports and cables
- Only one HDD connected for booting, nothing else connected
- Checked HDDs for bad sectors or s.m.a.r.t. errors, everyhing fine
- Tried different Bios Versions (0201,0301), with clearing cmos and loading defaults
- Went through every Bios setting one by one which could be causing this, like the USB settings, AHCI/IDE detection timeouts, OC settings at stock

My System:

MB: Asus P5QD Turbo
CPU: Core2Duo E4500
RAM: 2 x 1gb G.Skill F2-6400CL5-1GBNQ
GFX: Geforce GTX 275
HDD (used for booting atm): Maxtor STM3250310AS 250 gb
PSU: Tagan TG600-U33 600W

Anyone knows what could be causing this, any tips for further troubleshooting, possible motherboard defect?

03-25-2013, 12:57 AM
no one? :(

03-28-2013, 03:03 PM

03-29-2013, 11:40 AM
Your main problem is the Matrix Storage driver, it's not compatible with Windows 7 or 8.

Also, changing SATA modes from AHCI, to IDE, or RAID, is not something you can do any time you want to. That is asking for problems. If you installed your OS in IDE mode, for example, you just can't change to AHCI mode without a registry fix, so the correct driver will load. The same goes for AHCI to RAID mode. Otherwise the PC will BSOD.

Next, your board has three SATA controllers, the Intel ICH10R, a JMicron JMB361, and a Silicon Image Sil5723. Each of them is independent of each other, and uses its own driver. They are also configured separately in the BIOS, most importantly their mode of operation (IDE, AHCI, or RAID.) You must know which controller your drives are connected to, and which SATA ports on your board belongs to each controller. For example, you can't create a RAID array with one disk connected to the Intel SATA controller, and another on the Silicone Image controller.

For best results, use the Intel SATA ports for your OS drive. The main SATA configuration screen in the BIOS should be for the Intel SATA chipset.

Hopefully your OS drive is on an Intel SATA port, if not fix that before anything else. I would suggest putting all your drives on the Intel ports until you get to know your board better.

Your board's download page lists the Matrix Storage driver for Vista and XP only, not Windows 7. You need to uninstall that driver, it's not helping your situation. It will not work with Windows 8 or Windows 7. The Matrix driver is to old, your Intel ICH10R chip can use a much newer version of the IRST AHCI/RAID driver.

Uninstall the Matrix driver after checking that the SATA mode for the Intel ports is AHCI, with at least the OS drive on an Intel port. Reboot and hopefully the registry is not confused so much that it will not load the Windows 8 storahci driver, which replaces msahci.

04-05-2013, 04:14 PM
Thanks, but I'm pretty sure that the main problem is not the Storage driver as the strange delay starts by enabling AHCI regardless of Ports, harddisk, OS or driver versions. I only use the ICH10 Ports, others are disabled.