View Full Version : Drives not recognized by OS

06-05-2013, 08:21 AM
I have been at this for weeks. I am moving a copy of my Win 7 install to the P8Z77-V Deluxe MB. I used a backup software system that purports to do this transfer. Not so much.

I finally have a functioning (sort of) system. Things seem to work, except for one non-trivial thing. The BIOS recognizes all of the attached optical and hard disk drives. The operating system (win 7 64) only sees the boot drive.

I have installed essentially all of the drivers from the Asus web site. I have gone to device manager and disk management and told it to scan for new hardware. Nothing. It just does not see them.

Anyone have an idea for me to try?

So far the only thing I can think of is to try upgrading to Win 8 and see if the installation process resolves the problem. But I really do not want Win 8 until I see if Win 8.1 resolves the hideousness of Win 8. And that is at least a month away. Note: I really don't care if you like Win 8. Not the question being addressed.

06-05-2013, 08:39 AM
type disk management into control panel search and see if the drives show up in there,if so try assigning a different drive letter to them,they should show up then

don't format them or anything like that as you'll lose your data

06-05-2013, 09:56 AM
type disk management into control panel search and see if the drives show up in there,if so try assigning a different drive letter to them,they should show up then

don't format them or anything like that as you'll lose your data

That did not result in anything different than using disk management to search for new hardware.

06-06-2013, 04:18 PM
I believe I have found the problem, but I have been unable to fix it. A ATAPI controller shows as installed with Microsoft drivers. Trying to update does not find anything newer. I think there should be two controllers. One with Marvell drivers and the other with Intel drivers. ATA channel 0 and 1 used to be under that location. They are now under other devices together with a SATA controller.

None of these three devices have drivers loaded. I get the following message for all of them:

The drivers for this device are not installed. (Code 28)

This operation requires an interactive window station.

To find a driver for this device, click Update Driver.

I have tried multiple times to install the drivers. That message on the second line is a squirrely one from MS. I have not found a solution online except to do a cold install or go through some things I just do not understand with the command line interface. This mess may have been caused by an existing JBMicro driver from the original motherboard. I have gone through and removed other drivers that are no longer needed. But the JB one has been bizarre. It won't die. I think it is still associated in some fashion with the drive controller. The uninstall failed. Even though I have all permissions I could not halt or remove the driver directly. The uninstall program failed with an error in its' own code.

I really have no idea what I am poking around in. What I think is happening may or may not be true. Ideas?

06-16-2013, 05:04 AM
I am getting closer. An application that installed an intercept for optical drives appeared to be screwing things up. I uninstalled the application and now things are cleaner. I went from 7 optical drives and nothing else the the correct 2 optical drives.

What remains is one failure to load drivers that has been present through much of this process. I am getting this message - intel 7series/c216 chipset family sata ahci controller IE02 both when I try to install the Intel chipset software. When I boot, the OS tries to load the firmware for the SATA controller and fails. Same error message. I try to update the device from the MB files I downloaded from the Asus site. Same results. I have gone through and reinstalled all to the drivers from Asus that seem useful. This message occurred from the beginning and still persists after reinstalling the drivers. Every time I reboot, OS tries and fails to load drivers for this device.

I think this is the last thing that seems to be screwed up (but I have been wrong before).

Can anyone help me understand what is happening here and how to fix it?

06-16-2013, 11:34 AM
I noticed you did not mention the platform/hardware that your previous PC used, that you attempted to move to the new hardware. It might help to know what that is.

Moving an OS installation to different hardware can be very difficult, if not impossible. The drivers are only one part of it. Since you cannot easily uninstall the INF files of the other PC's hardware, that still exists in the OS installation. So when you try to install the new Intel chipset software (INF files), the installation program finds the old ones that are different, assumes this is different hardware, and fails.

You also have INF files from the old PC for hardware that does not exist on the new one, the JMicron SATA controller for example. Not to mention the Windows Registry entries for the old hardware.

The real fix is simple, install Windows fresh, and then all your other software. You'd be done by now instead of trying to deal with a Windows installation that will always be compromised.

07-04-2013, 11:39 AM
My previous comment about being close to a solution was overly optimistic.

Finally bit the bullet and did a clean install. I am going to lose a bunch of applications that were a one-time-install and I have no way of loading them again.

I am going straight to Win 8. If I am going to reinstall everything, it seems to make sense not to trust Win 8 to keep everything when I upgrade. I says it will, but I have seen more that one comment about strangeness after an upgrade. I have not been able to figure out how to get the Win 7 system to use UEFI boot. I will start a new thread with that topic. I am trying to get ready for Win 8. I have downlaoded the drivers from Asus. Still having a problem with one hard disk not being seen by the OS.

Boy, having to use IE is a nasty hinderence. I have used Firefox for a very long time. IE is seriously non-intuitive in my opinion. Way less than the last version of it that I used.

I would really like to get this finished and attempt to re-enter what is called "a life".