View Full Version : Raid Issues

11-20-2002, 01:41 AM
I am having issues with a new system build. I hav a SOYO KT333 Dragon Ultra (Platinum edition) with 512MB of DDR333 memory. My video card is a ATI Radeon 9000 Pro 128MB. The board has an embedded Highpoint Raid chip (HPT372)capable of supporting ATA133. I am using two Maxtor Diamond Max Plus 9 80GB ATA133 drives.

Here is my problem. I go into the Raid bios and select the drives and the type of raid (I want mirroring), then I duplicate the drives. I boot into dos to FDISK and format the drive(s). I reboot with an XP professional CD and it starts to install. I supply the drivers for the raid when asked, it continues to copy windows files and when it says "Setup is starting windows" It either locks up or blue screens. The error I got was something abouting trying to write to read only memory.

Any ideas?


11-20-2002, 02:59 AM
I used a minimal boot from a Floopy to get that going. But maybe by just switching the Radeon with an older card, installing XP and then after the Windows install, reinstall the Radeon.

11-20-2002, 03:03 AM

Sorry, I forgot to mention this. I have tried an older ATI card and a Creative Labs Banshee card as well.

11-20-2002, 04:06 PM
Do you have the raid set in the bios as the second boot device? When Windows does its first reboot, do you let the "boot from cd" time out? Is the raid array set to boot in the raid config utility?

11-20-2002, 07:06 PM
The raid is set as the 2nd boot device, with floppy being first and cdrom being 3rd. The Raid bios is set to have one of the hard drives as being the boot drive. Windows never does it's first reboot, it locks up when setup is trying to start windows.

11-21-2002, 02:35 AM
Have you checked BIOS or driver updates from SOYO?

11-21-2002, 05:45 AM
Yup, latest bios and drivers

11-21-2002, 06:35 PM
... and its a KT333 w/512 and what kinda HDD'S?
I might experiment with this, as we do get SOYO's in at work, maybe my Boss will let me take a stab at your prob with his stock... not sure... oh i see, 80GB maxtors... hmm dont think we have any of those in stock....

11-21-2002, 08:47 PM
Would it be an option to install Win 2K server and if that works fine try upgrading to XP?

11-21-2002, 11:41 PM
Not really, kinda sloppy.
What other options are in the HPT RAID Bios configuration area. I have the HPT 370 (i think) and it sounds like your doing it right, but the bluescreen sounds like the "build RAID array" function was never fully completed...

...and im not gonna be able to get my hands on that board for another couple weeks. Try calling SOYO's tech support...

11-21-2002, 11:47 PM
I can't remember them all off hand as the computer is not in front of me. I remember that I chose a mirrored array, selected one of the harddrives as the boot (the other shows up as hidden) and then duplicated the drives. Then I did the fdisk and the format. I'll look tonight and post the exact options tomorrow.


11-21-2002, 11:55 PM
and btw why did you choose mirroring over stripping?

OH! you know what. YOu may have chosen the wrong drive to boot up with... if you have the option to "call" a specific drive the HDD in the RAID bios (ie, you choose one of the drives to be the one written to and the one called HDD1 in the BIOS) you may have chosen the wrong drive. The RAID controller will deem one of the drives the master in a mirroring array and the other the backup (terms not exact, used here for understanding sake) the master gets written to and the backup gets doubled to by the controller, not windows. So the controller will say you can only write to one, the master. If you choose the wrong drive in the options, it may have screwed you over. Try rebuilding the array...

11-22-2002, 02:22 AM
I had origianlly chosen striping, but I thought that's where my problem was. With the stripe, my HD becomes a 160 but my MB only supports a 120. Still, it seemed to work as far as fdisk and format goes. I will look into the boot hard drive settings with the raid and the bios and let you know. I appreciate the help.

11-22-2002, 03:46 AM
I have finally gotten my reply back from SOYO support. They said that to use the Raid, both hard drives need to be set to master. I'll be giving that a try.

11-22-2002, 06:36 AM
When using two drives in any RAID configuration they must be the master of each RAID IDE chanel so if you have them master and slave on one chanel then that's ya prob. ;)

11-22-2002, 06:43 PM
Wiggo, you are correct. I did some different configs last night and found that once both drives were set as a Master on their own individual channel, and when I cleared the CMOS (to set everything back to default) the RAID worked. I guess I've been spoiled building multiple terabyte Arrays with Compaq servers... they make it too easy.

I have not completely loaded XP yet, but when I do, I'll post a reply with the overall performance.

I want to thank all of you who replied with suggestions, most of all, JediAgent. Who seemed to go well out of his way to get my system up and running.



11-24-2002, 03:43 AM
id still look into striping it, as mirroring is useless to you as the typical enduser. may just be better to have two drives not in raid if you cant stipe it.

11-24-2002, 11:21 PM
Jedi, I was able to stripe them. I have a 10GB NTFS C drive and a 142GB NTFS D drive. Now I get to spend alot of time filling that up. Thanks again.


11-25-2002, 12:49 PM
Good. Have fun. I like 'em the RAID...