PDA

View Full Version : Connecting thru network error, slow shutdown fix, XP Tweaks



Grim Reaper
11-29-2001, 09:16 PM
Firstly ill cover the networking error, this works the majority of the time but if not then start another thread & we will try & help u out...

Goto Control Panel & set it back to Classic View
Open Admin Tools
Open Local Security Policy
Expand the Local Policies tab
Select the User Rights Assignments
On the right-hand side find the key "Deny access to this computer from the network"...if guest is in here then remove it
Now find "Access this computer from the network" key & add Guest in here...if Everyone isn't in here then add it too.

when you install XP it doesn't enable the guest account for security reasons...sometimes even when you do enable this it still happens...


Now for the faster shutdown which has worked every time that ive seen...

Open up REGEDIT and goto "HKCURRENTUSER\Control Panel\Desktop\" and set the key "HungAppTimeout" to 5000(which is default) and make "WaitToKillAppTimeout"
4000 (20000 is default).

Also, go to "HKLOCALMACHINE\System\CurrentControlSet\Control\" and set the key "WaitToKillServiceTimeout" to 4000 too. That should make the shutdown complete in 4 secs.

Hope this all works!!! :thumb: :)


Edit: here is another tweak that i thought waz highly necessary...if you are trying to access another computer thru the network & it takes forever to load their files then this is what you need to do! open up regedit & goto HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Windows -> Explorer -> -> Remote Computer -> Name Space...
Remove the {D6277990-4C6A-11CF-8D87-00AA0060F5BF} folder...

also another one...if you have QoS Packet Scheduler enabled then goto Run type in gpedit.msc....now expand the "local computer policy" branch...expand the "administrative templates" branch in the Computer Configuration branch...expand the "network branch"..select the QoS Packet Scheduler branch...now in the right window double click the limit reservable bandwidth key...Enable this & change where it says Bandwidth limit % from 20 to 0...XP seems to want to reserve 20% of the bandwidth for itself...so if you try & download a big file then it'll download faster a lot faster now & make your computer gernerally faster...

my system won't shutdown because i haven't got ACPI installed (im assuming because i didn't install it at setup) which (only a theory, nothing can prove it unless i do a few reinstalls) that when ACPI isn't installed you don't have the APM tab in Power Options in control panel...so if you have APM tab in Power Options found in control panel, try enabling that and give it a go...

tell me how all of these go :) :thumb:
btw, keep on checkin this thread for more tweaks...

Edited 15th of April, added power off fix...

Beefy
11-30-2001, 07:44 AM
thanks for that.. I was waiting for the forums to open up again so I could find that out.. :thumb:

Grim Reaper
11-30-2001, 01:02 PM
no probs :)

MySTiCuSS
12-03-2001, 02:31 AM
WOW It worked!!!!!

Grim Reaper
12-03-2001, 10:09 AM
hehe, :) :)

aznx
12-03-2001, 01:14 PM
that tweak really helps GRIM
thanks a bunch

one should also run the tweak utility from microsoft...bootvis

Grim Reaper
12-03-2001, 05:12 PM
yeah i've run that...not bad for a microsoft 'tweaking' util!

aznx
12-04-2001, 08:10 AM
yeah, bootvis and tweakui.....RULES

Grim Reaper
12-08-2001, 07:12 PM
read my first post again, ive added some more tweaks/error fixes...

Bahamut Zer0
12-08-2001, 07:18 PM
The xp shutdown tweaks never did work for me, but since getting my 8KHA+ and reinstalling Xp i can shutdown fine.
The network tweaks were useful. Thanks Grim

Grim Reaper
12-08-2001, 08:13 PM
nps...

another thing that can help shutdowns is going to Control Panel -> Administrative Tools --> Services & setting the nVIDIA Driver Helper Service to manual...

cyboshaman
12-21-2001, 03:59 PM
THANX FOR THIS GREAT TWEAK ! IT REALY WORKS

--+++CYBOSHAMAN+++--
:thumb:

Grim Reaper
01-08-2002, 11:22 AM
hehe, indeed it does :D

Beefy
01-08-2002, 12:17 PM
you're just bathing in all this praise, ain't ya? :D

Grim Reaper
01-09-2002, 05:55 PM
ROFL, indeed i am!! :D :D

wuntvor
01-10-2002, 10:23 AM
I knew about all those tweaks, except for the shutdown one. and of course it does work, woohooo

:beer: :beer:

Anonymous
01-26-2002, 05:26 PM
Excellent Tweak, those sockcuckers at Microsoft were stealing my valuable bandwidth!

This Tweak is a must.

Jonny
02-06-2002, 05:27 PM
wat does this QOS packet thingy do anyway?

is it ok if you don't have it installed, cause i uninstalled it when i got my home network setup

Anonymous
02-07-2002, 10:38 AM
Grim Reaper,

No Sh*t - Thank YOU! All of a sudden it was taking about 18 seconds to shut down XP. Couldn't figure out what happened until I found this forum and saw you post on nVIDIA Driver Helper Service. I had just upgraded the nVidia drivers at about the same time I started the delay, so set it to manual, and boom, shut down in 4 seconds!!!

thanx,
dagger




nps...

another thing that can help shutdowns is going to Control Panel -> Administrative Tools --> Services & setting the nVIDIA Driver Helper Service to manual...

Anonymous
02-07-2002, 10:39 AM
Oh ya - how did you figure out this nVIDIA tweak?????????

dagger

wuntvor
02-07-2002, 11:14 AM
wat does this QOS packet thingy do anyway?

is it ok if you don't have it installed, cause i uninstalled it when i got my home network setup

if you uninstall QOS it will still reserve 20% of your bandwidth anyway, don't ask my why or how, but it does


edit: but does anyone know if it really uses the bandwidth unless MSIE/updates or anything like that are actually being used?

Grim Reaper
02-10-2002, 01:15 PM
:):)

as wuntvor said, xp likes to reserve 20% of the bandwidth to itself...with this tweak, we're taking it back :)

whoever the person was that asked me how i found out about it, i accidentally did it one day, & when i shutdown it went really fast, so i went thru each service to see which had sped it up...turned out it was the nVIDIA Help one...and this service isn't needed so i just left it as manual :)

dagger
02-12-2002, 01:05 AM
Grim Reaper,

It was me who asked about how did you find out about the nVidia process - I had just found this site and hadn't registered yet.

Thanx again for the tweak - XP shuts down in less than 5 seconds now :)

On another XP focused forum, they are saying that if you have not QoS services running (like using XP applications to run SIP VoIP, etc), then this 20% bandwidth reservation is an Urban Myth. From my experience, I have a 1.5M DSL service. I just upgraded from 98se to XP Pro, and I'm still maxing out the pipe at 1.45M downloads - same as in 98se............?

cheers,
dagger

Grim Reaper
02-12-2002, 01:55 PM
:)...


also, this other forum wouldn't happen to be wxperience would it? also, i haven't actually run tests to see if what they say is true...one of them there probably has, so ill just go along with what he says...:)


also, was it going at 1.45 before or after u did the tweak?

Anonymous
02-13-2002, 12:16 AM
Got a question... I have a desktop (P3-600, 256 MB RAM, XP Pro, ZoneAlarm, Norton 2002...), I share the Internet connection on it with a laptop (thru ICS).

The problem is after awhile of using the desktop, it changes to the Windows classic theme, then back to the XP theme (takes less than a sec), when this happens, the laptop's connection to the Internet (and the networked files on the desktop) completely dies! Can't do anything until I reboot the desktop. The laptop then is connected again (Laptop has static IP).

Thanx 4 any help!

dagger
02-14-2002, 01:33 AM
:)...


also, this other forum wouldn't happen to be wxperience would it? also, i haven't actually run tests to see if what they say is true...one of them there probably has, so ill just go along with what he says...:)

[dagger]: I believe it was wxperience forum.


also, was it going at 1.45 before or after u did the tweak?

[dagger]: I did not do any tweak (QoS?) - after loading XP and RASPPPOE, I tested throughput and it was the same as when I was running Win98se - and at the max throughput I can get with the 1.5M service. Thus - XP isn't "reserving" any bandwidth I can notice!

wuntvor
02-14-2002, 08:18 AM
same here dagger, but I still don't like the idea of windows being able to reserve any of my bandwidth :D

dagger
02-14-2002, 11:43 AM
wuntvor - I hear what your saying, but I'll take Window's side on this one IF it is done correctly.

As we all know, the internet protocol, TCP/IP, is a "best effort", variable packet length, connectionless protocol that was optimized for data transport across packet networks. This works fine for file transfers, which is non-mission critical, and non real-time bearer traffic. However, for other applications, like voice and video, these apps can't tolerate much in the way of delay, jitter, etc which cause unacceptable voice or video quality.

So, my limited understanding of what Microsoft has built into XP is applications/mechanisms to provide services beyond current "web browsing" computer services. I heard that, for example, they built in a SIP client, which supports VoIP, as well as many other multimedia services yet to be deployed. Thus, by implementing a "QoS" capability that enables them to allocate bandwidth for high priority services, this will allow these new type of services that can't tolerate say a VoIP packet stuck in a queue behind a large file transfer packet. It is one way IP is trying to accomodate required packet priorities that different services will demand. So, if I were to ever want decent VoIP service over my data connection using a SIP client on my PC while I'm using it to do file transfers/web page downloads, etc simultaneously, then I will need some sort of Quality of Service prioritization mechanism on my PC. If done correctly, XP's QoS feature may be of real value.

cheers,
dagger

wuntvor
02-14-2002, 12:00 PM
hmm, interesting poing, I hadn't even thought of that. Nice explanation of what exactly you meant too :thumb:

if/when I ever get into video streaming or whatever, I'll test it out and see IF it is done right ;)

ByRN
02-14-2002, 05:28 PM
Thanks for these Tweaks dude, they are heaps good.. I was just wondering though.. how do you find out that sort of stuff? did you just find it on the web somewhere? or what... :confused:

ck77
02-15-2002, 12:30 AM
------------------------------------------------------
Got a question... I have a desktop (P3-600, 256 MB RAM, XP Pro, ZoneAlarm, Norton 2002...), I share the Internet connection on it with a laptop (thru ICS).

The problem is after awhile of using the desktop, it changes to the Windows classic theme, then back to the XP theme (takes less than a sec), when this happens, the laptop's connection to the Internet (and the networked files on the desktop) completely dies! Can't do anything until I reboot the desktop. The laptop then is connected again (Laptop has static IP).
----------------------------------------------------

I've been having the same problem as this guy, my server keeps switching themes & my other PC (WinME, soon to be XP :D) is diconnected from the network... could it be XP Plus? (I installed it & then uninstalled it cos' there isn't much to it, just games & themes...) :rolleyes:

Btw, that tweak abt deleting the registry key (Scheduled tasks crap) is a godsend!:D :D :D

wuntvor
02-15-2002, 07:48 AM
Thanks for these Tweaks dude, they are heaps good.. I was just wondering though.. how do you find out that sort of stuff? did you just find it on the web somewhere? or what... :confused:

lots of previous windows tweaking and www.tweakxp.com has alot of tweaks on it :)

Anonymous
02-16-2002, 10:36 AM
I tried to follow the instructions but when I open admin tools, I don't see any kind of security tab.

devilish
03-06-2002, 01:21 AM
you guys are amazing, i went to the win xp tweaking guide on youre site(not forum) did almost everything, both guides, that broadband tweaking guide and i must say you people can tweak, i got the devilsown xp, standard it was about 35-40 secs boot time, now i got 4 secs...shutdown speed of 8 secs...really amazing

keep up the splendid work guys!!

greetz,


D :flames:

Frost
03-20-2002, 07:54 AM
Good Job Grim Reaper.. now can ya figure out my dillema in the post below it no why my XP is locking up on startup?? Wonder if I can edit my registry in the XP partition from running Window ME from another partition?? Hmmmm..

Thanks for the advice!!

My big eared cat thanks ya as well! ROFL

Mr.Tweak
04-08-2002, 12:48 AM
lots of previous windows tweaking and www.tweakxp.com has alot of tweaks on it :)

Aside from that, you can find them if you go looking for them... :)

Anonymous
04-11-2002, 11:41 AM
Ive been trying to use the tweak for the local security fix in XP, but I cannot find a Local security settings in the Administation tools.I am getting a "You do not have acess rights" when trying to print on another computer. How do I get the local security settings icons in Admin tools? Thanks

Mr.Tweak
04-11-2002, 09:23 PM
You need to be logged in as Administrator or with Administator rights.

Anonymous
04-12-2002, 06:57 AM
I have tried log in under administrator with safe mode and it still doesn't show up.The name I usually log in under has computer administrator under it in the user accounts menu in the control panel to, and when I log in under this name the local security icon in Admin tools still doesn't show up.Help??

Anonymous
04-12-2002, 12:21 PM
I disagree with what microsoft said about reserving

bandwidth for streaming intensive apps or games.

For an example, I'll use the game Counter-Strike.

When microsoft reserves the 20% bandwidth my ping on

Counter-Strike will be around 60(that's normal).

But there is a catch here, my choke and loss were an amazing

50-80 loss and choke, I couldn't play anyway. With the tweak,

my ping jumps to 200 but I could still play CS. So in conclusion,

despite Microsoft's comment on TCP/IP and how inefficient it is

at streaming, the QoS still does not offer the solution to the

problem.

Andy
04-12-2002, 03:29 PM
i'm guessing your on cable, since you get a ping of 60, in CS type in the console "rate 99999" (without quotation marks, of course) or however many 9s you see fit :) thats should help you with your choke

Grim Reaper
04-15-2002, 09:19 PM
thanks for the feed back...tell us how andy's fix goes...


also ive added a new fix to the first post...about enabling APM in Power Options in control panel...it seems to help a few ppl with the problem around here, i didn't realise itd actually work all that often when i posted, LOL :)

Chris
05-21-2002, 07:26 AM
for the right place it's HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Windows -> CurrentVersion-> Explorer -> -> Remote Computer -> Name Space......

U missed the CurrentVersion bit out
:afro:

shindoh
06-01-2002, 07:29 PM
I have a probem. With windows xp when i choose to repair my internet connection i sget the following error: The following steps of he repair option failed : Purging the DNS Resolver cache

Any ideas??

altangerel20
07-24-2002, 02:49 AM
Firstly ill cover the networking error, this works the majority of the time but if not then start another thread & we will try & help u out...

Goto Control Panel & set it back to Classic View
Open Admin Tools
Open Local Security Policy
Expand the Local Policies tab
Select the User Rights Assignments
On the right-hand side find the key "Deny access to this computer from the network"...if guest is in here then remove it
Now find "Access this computer from the network" key & add Guest in here...if Everyone isn't in here then add it too.

when you install XP it doesn't enable the guest account for security reasons...sometimes even when you do enable this it still happens...


Now for the faster shutdown which has worked every time that ive seen...

Open up REGEDIT and goto "HKCURRENTUSER\Control Panel\Desktop\" and set the key "HungAppTimeout" to 5000(which is default) and make "WaitToKillAppTimeout"
4000 (20000 is default).

Also, go to "HKLOCALMACHINE\System\CurrentControlSet\Control\" and set the key "WaitToKillServiceTimeout" to 4000 too. That should make the shutdown complete in 4 secs.

Hope this all works!!! :thumb: :)


Edit: here is another tweak that i thought waz highly necessary...if you are trying to access another computer thru the network & it takes forever to load their files then this is what you need to do! open up regedit & goto HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Windows -> Explorer -> -> Remote Computer -> Name Space...
Remove the {D6277990-4C6A-11CF-8D87-00AA0060F5BF} folder...

also another one...if you have QoS Packet Scheduler enabled then goto Run type in gpedit.msc....now expand the "local computer policy" branch...expand the "administrative templates" branch in the Computer Configuration branch...expand the "network branch"..select the QoS Packet Scheduler branch...now in the right window double click the limit reservable bandwidth key...Enable this & change where it says Bandwidth limit % from 20 to 0...XP seems to want to reserve 20% of the bandwidth for itself...so if you try & download a big file then it'll download faster a lot faster now & make your computer gernerally faster...

my system won't shutdown because i haven't got ACPI installed (im assuming because i didn't install it at setup) which (only a theory, nothing can prove it unless i do a few reinstalls) that when ACPI isn't installed you don't have the APM tab in Power Options in control panel...so if you have APM tab in Power Options found in control panel, try enabling that and give it a go...

tell me how all of these go :) :thumb:
btw, keep on checkin this thread for more tweaks...


Edited 15th of April, added power off fix... :bounce:
Hey Grim, i am lost after "open local security policy" on your first quote. thanks :bounce:

taps
08-29-2002, 08:06 AM
hmmm good stuff but ive seen/done it before, commonnnn give us the goods that arnt public :):):)...

tjgartner
09-03-2002, 03:54 PM
When I try to change the registry to make the shutdown time faster, as in the tip given here:

"Open up REGEDIT and goto "HKCURRENTUSER\Control Panel\Desktop\" and set the key "HungAppTimeout" to 5000(which is default) and make "WaitToKillAppTimeout"
4000 (20000 is default).

Also, go to "HKLOCALMACHINE\System\CurrentControlSet\Control\" and set the key "WaitToKillServiceTimeout" to 4000 too."

I can't change the registry values because my registry does not have HungAppTimeout or WaitToKillAppTimeout in HKCURRENTUSER\Control Panel\Desktop\

I did find them both in HKEY_USERS\.DEFAULT\Control Panel\Desktop

Does anybody know if that will work as well? Or, since I don't have those two values in HKEY_LOCALMACHINE, will my shutdown time be fast regardless, since there is no value of 20000?

Thx for the help!

Lurkersupreme
11-24-2002, 02:03 PM
Hello, first
Although my rating writes "newbie" on this board, I'm no PC newbie at all :devil:

Now for the challenge: since I'm a tweaker since W3.1, I couldn't help tweaking XP via various proggies or manu propria, with no problem at all until recently, when I stumbled into something peculiar, totally new to me

Brief, I seem to have lost the "stand by" button (It is grayed out now; inactive), along with the shut down and sleep function keys on the keyboard

Note that this happened after a HD format & clean install. They were not the first ones, but just now this happened. I tried another clean install, with the same result... Have you any clue about what could've caused this?

Thanks in advance! : peace2: :cheers:
LS

@ edit: My PC is p3/800, 128 MB RAM, no UPS, and same hardware configuration in last 2 years

Sunshine
12-02-2002, 01:41 AM
what's "QoS Packet Scheduler " and how do I know if I've got it?

(I ask because my boot up is quick, but my shut-down is slow)

thanks,

Sunshine :angel:

asklepios
12-09-2002, 06:48 PM
what's "QoS Packet Scheduler " and how do I know if I've got it?

(I ask because my boot up is quick, but my shut-down is slow)

thanks,

Sunshine :angel:

go to start-->control panel-->network connections
Right click on the icon of your local area network. Chose properties.
In the next wondows that pops up, you will see QoS packet scheduler mentioned (if you have got it installed ofcourse).

about wat it is...look for dagger's explanation of packet scheduler on page 2 of this thread. its a good one!

SmokeyMcPot
01-11-2003, 06:57 AM
ok, now i got a real question for you. I have seen both those tweaks and i know exactly where you got them from...:hmph:
lets see if you can live up to this reputation of yours in your thread.
Heres my question:

It has been my long desire since I recieved XP home to gain access to the QoS Packet Scheduler......What a conveinant thing for microsoft to leave out gpedit.msc on XP home edition. So I need to know how to free up the 20% of restricted access. Thanks

PersianImmortal
01-11-2003, 08:19 AM
Simple. To turn off QOS (Quality of Service), go to Services and turn off (Disable) the QOS RSVP service. Done.

If you want to make doubly sure, go into the Networking properties tab for your Connection and untick (and even Uninstall) the QOS Packet Scheduler item there.

All the tweaks in group editor can be performed by other means such as Registry editing or otherwise, so don't panic.

Dallows
01-30-2003, 06:29 AM
yo, I think I "accidently" installed a second network connection when I was trying to dl some type of "celeb" movie. Anyway, I only realized now that damn thing created it's own network connection, other than my normal Local Area Connection. But it says I can't delete it while it's connected or trying to connect. HELP PLEASE!!!

Chrysalis
04-13-2003, 01:21 AM
Out of interest what does allowing guest logins fix?

I think this is a bug I don't know about.

rcshamlin
11-18-2005, 05:13 AM
Now for the faster shutdown which has worked every time that ive seen...

Open up REGEDIT and goto "HKCURRENTUSER\Control Panel\Desktop\" and set the key "HungAppTimeout" to 5000(which is default) and make "WaitToKillAppTimeout"
4000 (20000 is default).

Also, go to "HKLOCALMACHINE\System\CurrentControlSet\Control\" and set the key "WaitToKillServiceTimeout" to 4000 too. That should make the shutdown complete in 4 secs.


Hope this all works!!! :thumb: :)

**** One thing no-one has mentioned on any website or thread I have found in reference to slow shutdown for windows xp is the size of your paging file. I experienced 3-4 minute shut down period and did a number of tweaks which didn't seem to help. As soon as I reset the paging file size to system managed size everything was fine and dandy- and faster because of the tweaks I had done previously.
"Start\Settings\Controlpanel\System\Advanced\Perfor mance\Advanced\Virtual Memory\Change" Set to system managed size ****

Yawgm0th
11-18-2005, 11:45 AM
Without reading your post or the thread, I'd say that you would have been more helpful two and a half years ago.