PDA

View Full Version : New Car thread... Please read in order to bolster posting in



JediAgent
01-06-2003, 03:30 PM
Yeah, this place needs some action. Its my favorite part of TT as im a car guy before im a PC nerd.

What was your first car...

ME?
1985 Toyota Cressida Station Wagon...

Sun spots... cigarette burns... a piece of wood fashioned to the top of the center console in order to comfort tall people with an arm rest... those were the days... no radio... and 2am trips to pasadena with my three best friends to go get boba... singing beach boys and TV themes... with my supra engine pulling 120mph tops speed w/ two burnt valves... memories...

Wiggo
01-06-2003, 04:53 PM
Ok I'll play this one. :D

<center><a href="http://austin1800.homestead.com/Memorabilia.html" target="_blank"><img src="http://www.homestead.com/austin1800/files/mattcooksmk11aa.JPG"></a>
<small>Go on! I dare ya to click on the pic
Mine was a skyblue 1967 Mk1</small>
:cheers:</center>

Valkyrie
01-06-2003, 09:24 PM
i dont have pics of it but it was a 1967 toyota rt40 corona

similar to the one in the pics which is my current 1969 model

its just a though but autos a comps go together really well now days and its only going to get bigger but if u could get some car computer tuners tweakers in here then more car lovers might follow

<img src="http://members.optusnet.com.au/hendrik_h/ZTiauxfiles/Misc/rona-series-opt.jpg" width="512" height="1000">

W

PrairieDawg
01-07-2003, 01:11 AM
No pics but my first car was a real ugly 1965 Chrysler Windsor with a 383 c.i.d. and a four barrel carb .... Good thing I worked at a gas station at the time.

Second car was a 1962 Mercury Monterey that I sold to my brother a few years ago so that he could restore it. (Looks like that project got put on hold ... might have to buy it back some day.)

Wiggo
01-07-2003, 01:30 AM
Can't ya dig up a pic from an online car club just to show us foriegners what the things looked like? :?:

Ok so somethin' like this for the first one (1967 though)

<img src="http://images.cardomain.com/installs/249000-249999/249357_2_full.jpg">

And somethin' like this for the other?

<img src="http://www.mercuryarchive.com/1961to1964/1962MontereyGreen.jpg">

God damn that me took a whole 2mins to Google (www.google.com) that up and post. :eek:
<center>:cheers:</center>

PrairieDawg
01-07-2003, 01:44 AM
LOL. Sorry :eek: You did good!

The styling (or lack thereof) on the Chrysler is pretty close to the 65 model ... mine was a gold/brown color (can't remember the name for the color but it wasn't real pretty).

The Mercury is real close except mine was/is a four door and bright red in color.

Wiggo
01-07-2003, 01:59 AM
Ok then this is listed as the '61 model. ;)

<img src="http://www.mercuryarchive.com/1961to1964/1961MontereySideLeft.jpg">

Wiggo's-sister
01-10-2003, 07:35 PM
Mine was a black Holden HT Premier

HT (http://www.holden-vs-ford.com/car-info/ht.shtml)

dirtydog
01-28-2003, 05:40 AM
Mine was a 1967 Ford Galaxie 500.

E^vol
02-01-2003, 01:00 PM
My first car was an '87 Nissan Maxima.

Moose
02-18-2003, 02:02 PM
Mine was a 1985 Toyota Corolla.

Spent many a day in this car on my Ls :D

Looked a bit like this one :shoot3:

http://users.bigpond.net.au/moose22/cars/corolla/corolla.jpg

Mr.Tweak
02-18-2003, 02:49 PM
1998 VT Holden Commodore... :omg:

Olie
02-18-2003, 07:22 PM
1982 toyota corolla

like that one of moose's
only more like a box and yellow

JediAgent
02-21-2003, 02:16 PM
Im actually driving my first car now that the trans on the 944 went out :( ... its such a crapper...


... love the sig Olie.

Bahamut Zer0
02-21-2003, 05:49 PM
My first car was an 85 Mitsubishi Cordia GSL. 1.8L carby piece of **** coupled with an ever ****tier automatic gearbox. Thankfully, It got taken out by a little old lady with lots of insurance. Today I got me a Cordia GSR. 1.8L engine, coupled with a 5speed gearbox and a mighty TC06 Turbo.

She goes hard. Stocko 13s on her atm, so she spins at the drop of a hat. Putting the 14s on her tomorrow. Running 10pound boost. Been pretty wet here for the past few days, and with the stock 13s, I havnt had a chance to wind her out. Yet.

Converting her to unleaded asap. leaded/premo is way too expensive atm. (that, and we only get Lead Replacement fuel, [email protected]#kall octane value and is just.....wrong)

Bahamut Zer0
02-26-2003, 04:58 AM
Updated pic with her shiny factory 14s:

Morgan_Lander
03-17-2003, 11:47 PM
First car: 1987 Honda Accord LX-i hatchback coupe manual transmission. Had well over 260,000 miles on it when I got rid of it. My currently defunct 1989 Escort has 160,000 miles on it.

My new 97 Chevy cavalier LS coupe has around 70,000 miles on it with most being highway miles.