Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 9 of 9

Thread: Graphics card help




  1. #1
    Join Date
    Jun 2010
    Location
    UK
    Posts
    3

    Default Graphics card help

    Hi guys,

    Been trying to find information for hours now and stumbled accross this site, basically i bought a new graphics card, Radeon HD5670 pci-express 2.0 and i installed it, booted up my pc makes all the noises it should but my monitor says no signal input, check video cable, now im starting to think its not compaitable with my Mobo,which is this one ASRock > Products > Wolfdale1333-D667 R2.0.

    Ahy help would be gratly appreciated.

  2. #2
    Join Date
    Sep 2002
    Location
    Central Alberta , Canada
    Posts
    1,019

    Default Re: Graphics card help

    I've no idea how much tech knowledge you have and I've fallen a bit behind in current technology but I can make a suggestion or two. I'm assuming with hybrid booster options that you probably should not disable the onboard video but, (assuming that you have the monitor plugged into the new video card) you should go into bios and set the PCI Express card (PEG1?) to boot before the onboard video. Double check the seating of your new card ... is it all the way in? Does the new card require you to plug additional power connectors to it? Is your power supply unit adequate for the new card?
    Antec 900 case (4 120mm and 1 200mm lighted fans + UFO flashing light set + 2 12" and 1 6" Mutant Mods meteor lights) - Aerogate ll thermal controller - Asus M2N-e SLI - AMD 64 X2 AM2 6400+ - Corsair TX650 PSU - MSI 450GTS Cyclone OC - 2 X 2GB Patriot Extreme Performance PC2 6400 RAM - SATA 320 GB Seagate HD, SATA 300GB Maxtor HD and IDE 80 GB Samsung HD - Floppy Drive/Card Reader Combo - LG SuperMulti Lightscribe 18x DVD RW - Plextor PX-716A DVD r/rw - Windows 7 Home Premium 64

    Crude but Effective ... it is a way of life.

  3. #3
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Graphics card help

    Also make sure your monitor is set to the way you are connecting the card, such as if you are now using HDMI connection you need to change the monitor to HDMI input if it was previously DVI, and visa versa

  4. #4
    Join Date
    Jun 2010
    Location
    UK
    Posts
    3

    Default Re: Graphics card help

    thanks for the replies,

    my psu is 650w and the card says it needs 400w and i un-installed all my old nvidia drivers and that didn' work, the graphics card is seated properly and i use a DVI connection, the fan on the card works but still getting no signal output, only thing i can think of is that the pc- express doesn't support it as i have read other peoples probs with pci 2.0/2.1 but not sure which mine is.

  5. #5
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Graphics card help

    PCIE 2.0/1.0 is supposed to be backwards compatible, but I guess it's possible that this is not always true.

    Did you use DVI on this monitor previously too? Just wanted to make sure the monitor is set to that.

    Can you test this card in another setup? Maybe the card is faulty

  6. #6
    Join Date
    Jun 2010
    Location
    UK
    Posts
    3

    Default Re: Graphics card help

    Thanks for the help guys, finally sorted it, took the card back to the shop and they tested it and it didn't work on the pc they have so they replaced t and all seems to be ok now.

  7. #7
    Join Date
    May 2010
    Location
    Taipei, Taiwan
    Posts
    96

    Default Re: Graphics card help

    Dear All,

    If you want to using HD5670 VGA card on Wolfdale1333-D667, I suggest you upgrade your BIOS to latest version L1.53 before insert this VGA card.
    BIOS download link

    Best Wishes
    Sean
    ASRock Tech Support Staff

  8. #8
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

  9. #9
    Join Date
    Dec 2010
    Location
    pto la cruz
    Posts
    2

    Default Re: Graphics card help

    i have the same problem but i can't find the L1.53 bios for wolfdale 1333-d667 on windows mode afuwindows i cant use the afudos couse my floppy is broken, thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •