Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Can't power on new 870 extreme3 with gskill ripjaws 1600 sticks




  1. #1
    Join Date
    Aug 2010
    Location
    canada
    Posts
    1

    Default Can't power on new 870 extreme3 with gskill ripjaws 1600 sticks

    Just got a 870 extreme3 and phenom ii x3 720 with a pair of gskill F3-12800CL7D-4GBRM 4gb sticks. Video card is an evga 8600GT 256mb card. For the purposes of testing all other devices were unplugged from the board and power supply.

    Here's the problem - I put it all together, mash the power button and the power comes on for almost a half second and it goes off. If I take out the sticks of ram, it'll power on and stay on, albeit with a no memory error code. Is my ram bad? I have no other sticks to test with, unless it's backwards compatible with DDR2, I could borrow the sticks out of my wife's PC.
    Last edited by tentacles; 08-13-2010 at 03:26 AM. Reason: add more information

  2. #2
    Join Date
    Dec 2010
    Location
    Henderson, NV
    Posts
    11

    Default Re: Can't power on new 870 extreme3 with gskill ripjaws 1600 sticks

    That sounds like you either have a stick of bad RAM or the RAM isn't getting along with the CPU. I would try researching CPU/RAM compatibility and use a fresh stick of something you know is compatible. There's a compatibility list on the AMD website.

    Most Big computer stores allow you to return ram... go purchase some for testing and if it doesn't work... well...


    Good Luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •