Asrock 775 Twins rev 2.0 (latest bios)
Sony NEC Optiarc High Speed (AD-5240S-01) SATA DVD-Writer
Windows 7 32 Bit
Ide Harddisk 250 GB, en 1 IDE DVD-Writer

I bought a new sata dvd drive, i only used IDE before, and I got a problem.
The dvd drive is clearly visible during the Uli Raid bios, but when I log in to windows it is not.

Now I went on looking into device manager, and saw that there was a Raid Controller as Uninstalled Device. I presume this is because of compatebility issues with windows 7.
I tried to install it, but automatic search was unable to find anything,
So I brought my motherboard CD-rom and started it and installed Sata Driver normally.
(Im not sure if a compatibility adjustment was needed, but I ran the installer through autorun, and am not sure which sata driver to pick manually since there are mutiple on the cd)
Installation completed, Rebooted. But still no dvd drive in explorer nor the RAID driver in device manager seems to be installed.

Though the installed software for Uli Raid gives this error:

Then I tried to install it through device manager again but then by picking it manually, but this unfortunately gave an error also:

I looked on the website for a driver update, but It seems to be the same driver I think and didn't work aswell.

Could someone please help me install the Sata/ Raid driver, im running out of options what to try quick..