Short version: PC reboots after 10-20 seconds on, then keep switching on and off 2-3 times a second. It did that before, but not using the re-set switch seemed to fix it. Have tried replacing almost everything else, xcept the M/B.

Whole story:
I've made a pc from old parts, one of them being Asrock's P4VM890 M/B.
Also a P4 3.2GHz CPU, 2X1GB RAMs, a new 500GB SATA2 WD HDD, a NEC IDE DVDRW (also have a BENQ one) and a GEFORCE 8500GT GPU, on a 350W PSU.

After some tweaking with the cables, I managed to make it work, almost everything except the restart button. When I connected that and tried to use it, the system would keep switching on and off (about twice a second) and I'd have to keep the power button pressed for a few secs or disconnect the mains cable to stop it. So, I just didn't use the restart button.

PC got up and running for about a week, working like a charm, running newish games etc, all temps checked and being fine etc etc.

Then, today, I moved it around some and disconnected and then re-connected a spare IBM 30GB IDE hard I'm using. After that it was still working for a while, long enough to start a format and windows install, for 30mins or so. Then I had to close it down (with the power switch) to do something else. After that when I tried to boot it, it keep rebooting after a few seconds, and then keeps switching on and off (like when I pressed the restart button, at the start - but restart is still disconnected). I usually barely have time to get into BIOS before the pc fails.

I've tried more or less everything, e.g. leaving only the absolut minimums on, using different RAMs, no HDD, even a different old GPU and a different 300W old PSU. Nothing seems to work.
That, together with the fact that it used to work fine just hours ago, with the same exact configuration, makes me suspect that it's not a power problem, nor a CPU/RAM/GPU problem. I also tried using a different case's power switch to run the pc (and even starting it with a screwdriver, without any power switch connected). Always starts, but goes to that re-boot cyclce after some seconds.

I suspect there is something wrong with the M/B, but not sure what it could be, since it's working fine aside from that (was on for 2-3 days, playing games and such, just fine).


Since I have no other spare M/B and I don't want to spend money on a new M/B for an old pc, any suggestions would be very welcome.
Thanks.