Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Trouble updating BIOS on ASRock X58 supercomputer




  1. #1
    Join Date
    Dec 2010
    Location
    NYC
    Posts
    1

    Default Trouble updating BIOS on ASRock X58 supercomputer

    Hi.

    I need to update my BIOS for my ASRock X58 motherboard. But everytime I try to run the .exe I get an error message from the updating program which says "Error: File ROM ID Incorrect." I've tried to update through Windows, and also from a bootable USB, but I got the same error message both ways. I've tried several different BIOS updates (earlier than the most current), and I get the same error message for all of them.

    If anyone has any insight, I would greatly appreciate it.

    Thanks,
    Steve

  2. #2
    Join Date
    Feb 2011
    Location
    Paris, FRANCE
    Posts
    1

    Default Re: Trouble updating BIOS on ASRock X58 supercomputer

    Hi, I updated my BIOS around this period. It was the third update and it worked like a charm. I made it under Win7 Pro 64bits. Bios is now 3.40. Good luck.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •