Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 7 of 7

Thread: ASRock G43Twins-FullHD trouble




  1. #1
    Join Date
    Dec 2010
    Location
    England
    Posts
    11

    Default ASRock G43Twins-FullHD trouble

    I recently installed the ASRock G43Twins-FullHD motherboard into my PC. All the stats of the G43Twins-FullHD motherboard are equal or better than my previous motherboard. However, computer performance in almost every area has decreased since I have installed it. I have followed the instructions from the manual about changing the jumpers so that the computer can run with FSB 1333MHz and DDR2 1066.

    Also, why can I now only use 3.19GB of RAM whilst on my old motherboard I could use all 4GB?

    Could someone please tell me what I am doing wrong!!! :)

    CPU: Intel Core 2 Duo E8400
    Graphics Card: Nvidia 9800GTX+ (with latest drivers)
    Motherboard: ASRock G43Twins-FullHD
    RAM: 2GB DDR2-1066 (x2)
    OS: Windows 7 64-bit (with latest updates)

  2. #2
    Join Date
    Dec 2010
    Location
    England
    Posts
    11

    Default Re: ASRock G43Twins-FullHD trouble

    I have now downloaded the latest update for the chipset from intel but it hasn't made much difference.

  3. #3
    Join Date
    Dec 2010
    Location
    England
    Posts
    11

    Default Re: ASRock G43Twins-FullHD trouble

    I have updated the bios to the newest version but it hasn't made any difference.

    Any help is much appreciated.

  4. #4
    Join Date
    May 2010
    Location
    Taipei, Taiwan
    Posts
    96

    Default Re: ASRock G43Twins-FullHD trouble

    Dear Ilikeporkpie,

    Please kindly adjust "Memory Remap Feature" to [Enabled] under BIOS to try.
    ( BIOS/ Advanced/ Chipset Configuration/ Memory Remap Feature )

    Thanks!

    Have a nice day
    ASRock TSD
    ASRock Tech Support Staff

  5. #5
    Join Date
    Dec 2010
    Location
    England
    Posts
    11

    Default Re: ASRock G43Twins-FullHD trouble

    Success! I toggled the "memory remap feature" to enable and now I can use all 4GB of Ram. Thanks for the help!

  6. #6
    Join Date
    Dec 2010
    Location
    England
    Posts
    11

    Default Re: ASRock G43Twins-FullHD trouble

    I have another question:

    The drivers on the CD supplied with the motherboard only seem to go up to versions for Windows Vista. Are there any Windows 7 hidden on the CD which I can't see, or any I can download from the internet? Specificly drivers for the "PCI IDE Controller" and the "Serial ATA Controller".

    The motherboard won't operate properly with Windows 7 without the specific drivers.
    Last edited by Ilikeporkpie; 12-31-2010 at 07:47 AM.

  7. #7
    Join Date
    Dec 2010
    Location
    England
    Posts
    11

    Default Re: ASRock G43Twins-FullHD trouble

    Bump

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •