Hi, everyone, happy new year .

I recently bought an ASRock P45X3 Deluxe motherboard, on which I have installed the following components:

Two 1GB DDR 1333MHz Kingston modules KVR1333D3N9K2/2G
Intel Core 2 Quad Q9650 3GHz

2 SATA disks:
Western Digital 1TB Black Caviar
Maxtor 80GB

1 PATA disk:
Seagate 300GB 7200.9
Gigabyte GV-R465OC HD 4650 1GB DDR2 Graphics Card

The motherboard came loaded with the 1.2 BIOS revision, the first symptom I notice was that every time I restarted or turned on the PC, it booted for a second then shuts off and it booted alright again. I updated the BIOS to revision 1.5, and that problem kind of disappear, it just happens when I add a new component. Till this day the PC have worked fine, but anyone knows how to fix this problem for sure, I'll appreciated the help.

But then appear a new problem, the Intel (R) Virtualization tech option is DISABLE in the BIOS MENU, and according to the motherboard's manual: "This option will be hidden if the installed CPU does not support Intel (R) Virtualization Technology." And this is absolutely not true, because the Q9650 does support that feature.

The option only appers ENABLE (I mean, I can Turn On and Off this feature), when I stars the PC from cold, and when windows is loaded and restart the PC, this option is DISABLE again.


The things I have tried:
-Update the BIOS
-Clearing the CMOS
-Reupdate the BIOS

Any advice will be appreciated.