Hello,

I just ordered all my components to build a machine

ASRock X58 EXTREME6 LGA 1366 Intel X58 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
Intel i7-950 3.06 cpu
HIS Radeon 6970 2gb video card
WD 10000rpm 300gb Velociraptor sata HD
G.SKILL Ripjaws Series 12GB (3 x 4GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666)
ASUS Black 24X DVD+R 8X DVD+RW
CORSAIR CMPSU-750TX 750W ATX12V / EPS12V SLI Ready CrossFire Ready 80 PLUS

I have assembled everything and Boot the machine and the bios screen comes up and I am able to go into the screen and 30 seconds to 1 minute after being on the machine just powers down. I have tried 1 stick of Ram in multiple Dim's of the gskill and also tried some samsung ddr3 ram I have and it also does the same.

I have unplugged all components except for the mobo, video card, powersupply and memory and the same thing happens, boots to bios screen then power's down.

When i stick only one stick of the gskill ram i get 3 beeps then a pause and 3 beeps. When using only 1 stick of the samsung ram it post to bios screen and powers down.

The only error message I have been able to see on the post screen is CMOS settings are not right, I've cleared the cmos, taken the battery out and power cycled the machine multiple times. Any help would be appreciated as this is the 2nd mobo in two weeks that seems to be Dead On Arrival. Had all the parts for 3 weeks now and no running computer :(

Thanks.