Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: ASRock 890GX Extreme 4 DVI-D problem




  1. #1
    Join Date
    Oct 2010
    Location
    Scotland
    Posts
    4

    Default ASRock 890GX Extreme 4 DVI-D problem

    My setup ran well for a few weeks then the monitor kept going blank for a few seconds when connected to the DVI-D port. It works fine on the VGA/D-sub port. It also works with no problem on another PC with a DVI-D port.

    I'm using the BIOS V1.0 (i don't think there is a more up to date version) and the suppled drives utilities from disk (v8.70). Again, no evidence of a more up to date version.

    Should I uninstall the video driver via Device Manager and re-install from the disk?

    Suggestions would be welcome.

    Sandy

  2. #2
    Join Date
    May 2011
    Location
    Rudehen, Tehran, Iran
    Posts
    302

    Default Re: ASRock 890GX Extreme 4 DVI-D problem

    From the manual, you cannot connect DVI and HDMI simultaneously; Although, it is a bit unclear! To have read these lines (from manual):

    Quote Originally Posted by Manual of "890GX Extreme4"
    Connect DVI-D monitor cable to VGA/DVI-D port on the I/O panel, connect D-Sub monitor cable to VGA/D-Sub port on the I/O panel, or connect HDMI monitor cable to HDMI port on the I/O panel.
    It is so suggested that D-SUB and HDMI are mutually exclusive, while regarding the following warning, these are DVI and HDMI:

    Quote Originally Posted by Manual of "890GX Extreme4"
    DVI-D and HDMI ports cannot function at the same time. When one of them is enabled, the other one will be disabled.
    IMHO, something has to be revised!

  3. #3
    Join Date
    Oct 2010
    Location
    Scotland
    Posts
    4

    Default Re: ASRock 890GX Extreme 4 DVI-D problem

    Thank you Bahram. I cannot comment oneway or another, I'm not using the HDMI port asnd don't have an HDMI connection on my monitor.

    Sandy

  4. #4
    Join Date
    May 2011
    Location
    Rudehen, Tehran, Iran
    Posts
    302

    Default Re: ASRock 890GX Extreme 4 DVI-D problem

    Disconnect the monitor from VGA and connect it (only) to DVI port. If you see display when turning on the computer but not in os, software problem; Else, hardware defection.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •