1. Disable legacy usb support in bios.. i was pulling my hair out with this (what i have left) i was sure i pulled the mouse out before but ov not, i removed one thing after another but couldn't find the fault until i removed the mouse.. i have a cool master sentinel advance mouse, but the pc did work fine for the 1st week then started to hold on start screen error 92 time to time until one day it wouldn't get passed this.. so i removed the mose disabled usb legacy in bios and hey presto. :)