I just put together my new computer, which is something I've done dozens of times and came to a first with this problem. I have an "ASRock 775XFIRE-ESATA2 LGA775 Motherboard ATI CrossFire" in this setup and am not getting a picture on any of my monitors, and later after trying a different power supply, the Power LED just stays on and the fans remain spinning, even after holding the Power Button. If anyone has a solution, please post it.

Things I've already tried:
1. Different Power Supply
2. Using different RAM sticks
3. Using a different video card & tested the current one, which works on the other computers
4. Disconnected all additional attachments
5. Disconnected the CD-Rom and Hard Drive
6. Placed RAM in different slots
7. Used different Monitors and VGA cords
8. Used different Video Output slots
9. Tested all components (except CPU) on other computers, they all worked.
10. Changed CMOS Battery
11. Cleared CMOS Jumper Settings

The fan works; the only time there was a "Beep" was when I tested it without the Hard Drive & CD-Rom. I can't get in to change the Bios settings because I can't get a picture.

I'm using these components:
1. ASRock 775XFIRE-ESATA2 LGA775 Motherboard
3. 500GB SATA Hard Drive
4. ATI Radeon HD 5450 Video Card (PCI-E), 1GB DDR3
5. Single 2GB 667 DDR2 Ram stick
6. 3.4 Ghz Pentium Dual-Core CPU

Please post any solutions to both of these problems: Orginally just no picture, then after changing power supplies then changing them back, the Power LED and Fans stay on. Thanks in advance.