Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?




  1. #1
    Join Date
    Jun 2011
    Location
    Sydney, Australia
    Posts
    10

    Default AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    Hi all

    Forum first timer here. Hoping to get some help.

    Just got an AsRock Extreme4 and am using its onboard GBe port, and want to get WakeOnLan switched on. Have done this on many PCs before so feel i do know what i'm doing here, but i just can't seem to find the settings on the AsRock UEFI.

    Usual procedure is
    1) turn on WOL in BIOS
    2) enable magic packet on NIC Advanced settings in device manger
    3) enable the device to power windows on in the "power management" tab of the NIC in device manager
    4) get the MAC address using "ipconfig /all" and use that to sends a magic packet form another PC to wake from Suspend/Sleep/Hibernate/Soft-Off

    the bit that i'm getting stuck on is #1 (#2-4 is done with no success). in the UEFI i fonud optinos such as (paraphrased) "allow ring-in power on", "allow PCI Wake" and "allow boot from LAN", and turned them all on just in case with no luck

    hoping i'm missing some hidden menu somewhere. any ideas?

    OS is Win7 x64 Ultimate.
    My old PC performs WOL as expected (on the same LAN, same switch even). no improvement if i change network cables.

  2. #2
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    Dear dogoth,

    If you want to use "Wake on Lan" function, please kindly adjust "PCI Devices Power On" to [Enabled] under BIOS to try.
    ( BIOS/ Advanced/ ACPI Configuration/ PCI Devices Power On )

    Thanks!

    Have a nice day
    ASRock TSD Emily

  3. #3
    Join Date
    Jun 2011
    Location
    Sydney, Australia
    Posts
    10

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    thanks emily, but i already have that option switched on (and i know its working as i have a TV Tuner card which uses PCI Wake to turn my pc on via remote). WOL still is not working.

    i can confirm that the light on the NIC is on when the computer is off/suspended so the LAN card is still awake. also it blinks when i send a WOL packet, but the pc does not turn on.

    what else can i try? is there a specific WOL packet style i need to send (rather than the generic 'magic packet')? any special payload?
    what tools do you use in AsRock to test this?

  4. #4
    Join Date
    Jul 2011
    Location
    Dallas
    Posts
    5

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    It might be a device setting in Windows. I had the same issue. To fix it I went to the network attapter setting and on the "Power Managemnt" tab, check "Allow this device to wake the computer" and un-check "Only allow a magic packet..."

  5. #5
    Join Date
    Jun 2011
    Location
    Sydney, Australia
    Posts
    10

    Unhappy Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    Thanks for the suggestion MrSparky_TX, but i have already tried all combinations on the Power Management tab, along with trying the two WOL related items on the Advanced tab (WOL Speed and Wake Up Capabilities). Also tried all the ACPI related UEFI toggles that are shown. I have also tried a variety of different WOL packet generator software, all of which successfully work on all my other PCs.
    Also tried waking from S5 and from S3 in case it is only working from specific ACPI states.

    still no luck

    Has anyone been able to get WOL working on this motherboard?
    Can someone from AsRock confirm the exact combination that they have used to get this working on the intergrated Broadcom NIC?

  6. #6
    Join Date
    Jul 2011
    Location
    Seattle
    Posts
    37

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    I did get wake on lan to work. I <s>set the PCI wake up option and</s> made sure the Broadcom device had the wake on LAN options set. My naive approach was to try to browse to the ip address assigned to the device. That didn't work. However, a NetAwake application running on an ipod touch sent the right packet to make it wake up.

    The broadcom device is set to defaults for me. Those are "both" under the Advanced tab "Wake up capabilities" for how to wake up. On the power management tab, I have "allow the computer to turn off this device checked. I probably should uncheck that but it still woke up. Allow this device to turn on the computer is checked. Only wake on magic packet is not checked.

    My sleep state was whatever Windows uses when I click Sleep on the Start menu.

    I checked the BIOS settings and they were not as I remembered so I corrected the text above. I had not set PCI Devices Power On. Sure thought I had. The BIOS settings are:

    PCI Devices Power On: Disabled
    Ring-in Power On: Enabled
    RTC Alarm Power On: By OS

    Sleep is probably an S3 state, and sending a wake up packet woke the machine up. I tried S5 yesterday, soft off, where I can see that the transmit/receive lights are blinking on the network interface, but the operating system is shutdown. The machine was unresponsive to wake up packets in this state.

    Another test shows that S5 can also respond to wake up packets if the PCI Devices Power On is Enabled. <s>So for S3, only Ring-in Power On is required, but</s> for S5 <s>both Ring-in and</s> PCI Devices Power On are required. (PCI Devices Power On probably should be called ACPI PME but it does mention that in the comments. )

    Tested again with Ring-in Disabled. When sleeping, the Broadcom device still responds to the wake up packet with both Ring-in Disabled and with PCI Devices Power On Disabled. Just repeating that wake up from a soft off (s5) state requires PCI Devices Power On to be Enabled.
    Last edited by brukster; 07-11-2011 at 06:30 AM. Reason: added BIOS settings and s5 info

  7. #7
    Join Date
    Jul 2011
    Location
    Seattle
    Posts
    37

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    I added comments in the entry above. Sorry if bumping the thread like this is bad :)

  8. #8
    Join Date
    Jun 2011
    Location
    Sydney, Australia
    Posts
    10

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    thankyou very much for the extremely detailed response brukster

    despite trying all combinations including your exact settings i cannot get it to work.

    the only conclusion i can come to is this functionality is faulty on my motherboard (quite a strange part to be faulty as its such a specific fault, would have expected the entire NIC not to function rather than this exact sub-component of it)

    anyway, the only solution here is to get a second NIC, GBe Intel NICs go for about $15 on eBay so its not a big expendeture, but its annoying that one of the PCI slots will need to be used.
    could even dig up an old 100mbit nic i have lying around and use it purely for WOL (ie not set up an ip in the OS so not using it for any traffic, only use it for its MAC address and its WOL feature). neverthelss the PCI slot will need to be used up.

    unless someone has a brainwave or is able to reproduce my situation, this thread could be concidered closed

    thanks to all for replying

  9. #9
    Join Date
    Jun 2011
    Location
    Sydney, Australia
    Posts
    10

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    PS. i owe you at least three reboots brukster :) thanks for the attempts

  10. #10
    Join Date
    Jul 2011
    Location
    Seattle
    Posts
    37

    Default Re: AsRock Extreme4 Z68 - Wake On Lan - where in uefi?

    Sorry to hear that you couldn't get it to work. I was happy to play and learn some things. Some of which even makes sense to me now, like having to use a MAC address instead of an IP address to do the WOL.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 20 users browsing this thread. (0 members and 20 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •