Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock Z68 Extreme4 - Crashes With Catalyst Drivers




  1. #1
    Join Date
    Jul 2011
    Location
    Denmark
    Posts
    2

    Default ASRock Z68 Extreme4 - Crashes With Catalyst Drivers

    I have recently done a near full system upgrade, my current build looks as such:

    ASRock Z68 Extreme4
    Core i5 2500k
    8GB DDR3 Kingston 1600 CL9
    XFX HD 5770
    128GB C300
    2TB Hitachi HDD
    Asus Xonar DS
    Corsair 620HX PSU

    Now, for the initial installation of Windows 7 x64, I had not plugged neither the Hitachi HDD nor the XFX 5770 in. I loaded it up, installed all drivers and everything seemed to be working fine.
    Then, I installed the HDD and the discrete video card and the troubles began. After installing Catalyst 11.6, some applications simply started crashing when I tried launching them - for instance MSN Live Messenger and Steam. Also, Flash doesn't seem to work at all - it simply crashes in Firefox 5 when I try to view a video on YouTube, for instance.

    I tried uninstalling the Catalyst driver and everything worked fine once again. I also tried using Catalyst 11.5, but with the same result.

    I also had some issues installing the Eltron 3.0 USB Driver - everything simply locked up in Windows when I tried to do so. I have since disabled USB 3.0 in the BIOS as I don't have devices that make use of USB 3.0 anyway.

    I have run a full pass of memtest86 and about half an hour of prime95, both of which gave no errors. I can also run 3DMark11 without problems.

    Any ideas what might be going on?

  2. #2
    Join Date
    Jul 2011
    Location
    Denmark
    Posts
    2

    Default Re: ASRock Z68 Extreme4 - Crashes With Catalyst Drivers

    Seems like something was flakey with DirectX. At least, running the End-User Runtime Installer fixed everything. *knocks on wood*

    Download Details - Microsoft Download Center - DirectX End-User Runtime

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •