Well, I've been all over the web and back. I guess this thread will be my last hurrah, as ASRock support has contacted me and said that they will RMA my board, about 2 minutes ago. But I figured, what the heck, I'd give anything a last shot to keep from having to RMA this dang thing...

Here is a video of the problem: http://www.youtube.com/watch?v=lKQnvSoi8zA

H
ere are the things I have tried: 1 stick of RAM in slot 1, the other stick then in slot 1, 1 in slot 2, then the other there. Each time I have gone into bios and changed the voltage to 1.5 manually. Tried disabling PLL overvoltage, and all sorts of other settings in bios. Disconnected all USB devices except the keyboard. I picked up an SSD recently and decided to try a fresh install of Win 7 on it to see if that changed anything. It installed Windows fine, but as soon as it booted into Windows for the first time, it just rebooted right away, and then went back to this loop.

System was built at the beginning of May. I was playing the other night, then went to boot up the next day and this started happening. Nothing changed between then and now. All of the boot loop things I find on the net seem to be different than mine. Most reboot much sooner.

RIG:
i5 2500k
ASRock P67 Extreme4
Mushkin 2x2gb 1333
Galaxy 560 Ti
PC Power and Cooling 760w PSU
Hyper 212+ cooler
Crucial M4 SSD
Samsung Spinpoint f3 1TB

:(