Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: ASRock Z68 Extreme4 No Picture




  1. #1
    Join Date
    Jul 2011
    Location
    South Carolina
    Posts
    1

    Default ASRock Z68 Extreme4 No Picture

    This is my second build and my first time trying an ASRock mobo.My problem is that when i start up the computer the mobo wont post. I know that "cha_fan1" port has a short because i plugged that in aswell. When that was in use the mobo would not start but with it off it starts but wont post.

    Specs:
    Mobo: ASRock z68 Extreme4
    CPU: i7 2600k 3.4ghz
    GPU: XFX Radeon HD 6970 2gb
    Sound Card X-FI Titanium 7.1
    Internet Card: Killer NIC
    HDD: 2x 750 gb WD Black 7200 rpm
    PSU: Ultra x3 1000w ( I was wondering if there was a conflict between this and the mobo because its a rather old psu from over 4 years ago.)

    Any help would be very much appreciated.

  2. #2
    Join Date
    Aug 2011
    Location
    Ireland
    Posts
    1

    Default Re: ASRock Z68 Extreme4 No Picture

    I am having the same problems. the system will power up but no picture or error codes either. if I use my Radeon 5850 it will put its fan speed to full but no picture. If i just use the on-board gfx either D-SUB or DVI no picture.

    • ASRock z68 Extreme4
    • Intel i5 2500K
    • Stock Cooler
    • Corsair TX650 power supply
    • 8GB-Kit (2 x 4GB) G.Skill RipJaws-X PC3-12800U CL8
    • Radeon 5850 / On-board
    Any help would be greatly appreciated.


    *EDIT* The Diagnostic LED does not show any codes.
    Last edited by rkell; 08-21-2011 at 06:17 AM. Reason: Dr Diagnostic LED

  3. #3
    Join Date
    Jun 2011
    Location
    Asia
    Posts
    43

    Default Re: ASRock Z68 Extreme4 No Picture

    try to read the manual to check if there any cable you forget to install, or any loose cable
    you could also check the Dr. Debug LED, and check the last number when you turned on the pc and see the manual to see which one making the pc stuck/no picture

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •