Hello,

I just purchased an ASRock P67 Extreme4 along with two Radeon 6850s. I had an older crossfire bridge connector that I'm attempting to use, but I'm getting an error in the Catalyst Control Center that states, "CrossfireX internal bridge interconnects linking your crossfirex graphics cards are not properly connected." There is only one bridge interconnect on my card, and it's connected. I tried cleaning it.

All the power connectors are connected, including the molex crossfire connector on the board. I've tried reinstalling the latest Catalyst drivers with both cards in and alternating each individual card. This is with Driver Sweeper in safe mode to clear them out each time. I'm not having much luck. The cards work okay individually and they both show up in device manager when they're both connected. GPUz shows crossfire as being disabled, and shows both cards. Is it possible the bridge connector is faulty? I only have one at the moment but have ordered another to test.

Any thoughts would be appreciated.
Thanks!

i5 2500k
Rosewill 850w
Windows 7 x64
8gb ddr3 1600