Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: ASRock P67 Extreme4 random hang on POST screen (code 98)




  1. #1
    Join Date
    Aug 2011
    Location
    Finland
    Posts
    1

    Default ASRock P67 Extreme4 random hang on POST screen (code 98)

    Hello TweakTown!

    I bought new rig in May this year and after a month I noticed problem when cold booting the machine.

    E: Looks like I was wrong about this. The thing is that I was talking BS about I waited 10-15 minutes and nothing happened. I dunno, I remembered wrong or something.

    Today the problem occurred again and I waited about 2 minutes and it resumed booting (Windows startup screen showed up). But the other problem is that my USB keyboard did not work in Windows. I swapped the the received to another USB slot and it worked again.

    Makes me think if it's something to do with this wireless keyboard from the beginning. I need to test this forward with my wired USB keyboard.

    -----------------------------------
    Old text:
    The screen is black and there is only texts in upper left screen "American Megatrends..." the manufacturer information I guess and lower right screen "98" which is the same number that is in the Dr. Debut digital display on the motherboard. Manual says about this code: "Console input devices connect".

    So far I've done these:
    -tested the HDD with Lenovo PC-Doctor, no errors/bad blocks found
    -changed the SATA-cable to new one and SATA-port to different one on motherboard
    -memory tested with memtest (8 passes), no errors found
    -BIOS upgrade to 1.80, didn't help
    -cmos reset and battery away 15 sec from mobo

    My rig:
    Intel Core i5-2500K (not overclocked)
    ASRock P67 Extreme4, P67 (B3)
    Sapphire Radeon HD 6950 2GB (not overclocked)
    Samsung Spinpoint F3 1TB
    Corsair AX 750W
    Elixir 4GB PC3-10667U CL9-9-9-24 (DDR3-1333)
    LiteOn iHAS124 DVD-RW
    Nexus Breeze with Nexus 120mm fan (http://img.tomshardware.com/us/2004/...eze-sysfan.jpg)
    Logitech VX Nano Mouse (1 usb receiver)
    Microsoft Wireless Keyboard 3000 (1 usb receiver)
    Buffalo Wireless usb receiver WLI-UC-G300N
    Lacie External USB HDD 2TB (it's powered off during system start up, I start it after Windows boots)

    -----------------------------------

    Yesterday (31.7.) when it happened once again I made these changes, so we need to wait and see if it did help this time.
    -upgraded BIOS to 1.90
    -made sure the PSU cables are connected correctly and seated well (motheboard end, PSU end and all the other components like HDD, GPU etc.)
    -unplugged the LiteON DVDRW drive from motherboard and PSU
    -plugged the PC speaker to the motherboard, so if the next time this happens it might beep and give some hint
    -plugged the PSU power cord straight to the wall socket (the cable went to extension cord before)

    So any hints to this case? Motherboard related, PSU related? I don't have any extra mobos or PSUs available so I could test those.


    E: Actually there has been 2-3 freezes during gameplay in these 2 month (so that I had to turn the computer off), but I don't know if it is related.

    Thanks in advance!
    Last edited by fokkusu; 08-02-2011 at 02:06 AM. Reason: things got different

  2. #2
    Join Date
    Aug 2011
    Location
    KS, USA
    Posts
    2

    Default Re: ASRock P67 Extreme4 random hang on POST screen (code 98)

    fokkusu-

    This happens to me as well, but only after I've applied -any- kind of overclock and try to power on the system after having shut it down.

    It is worth noting that the system with an extremely modest overclock is prime95 stable, and I can reboot to my heart's content with no problems. This code only occurs after the system has been shut down. As you've noted, per the manual code 98 is "Console Input Devices Connect". The next step that doesn't start (code 99) is "Super IO Initialization", but since 98 doesn't pass I'm inclined to believe you're correct in suspecting input devices are the culprit (i have a wireless keyboard/mouse as well).

    I'll be sure to post any additional info/solutions I come across so we can compare notes. So far, it appears that this isn't specific to USB init failure due to overclocking as I'd thought (since you reset CMOS and still have the problem). I'm currently using front panel USB ports which of course connect to a USB header... going to experiment with using the ports on the back and scouring the BIOS for other settings.

    EDIT - At least in my case, you were right on the observation that it will proceed to boot after a few minutes. However, I did have to reseat the USB receiver for my mouse before it would be recognized. The search for a fix continues...
    Last edited by nullity; 08-08-2011 at 03:44 AM. Reason: observed POST will continue after code 98

  3. #3
    Join Date
    Aug 2011
    Location
    KS, USA
    Posts
    2

    Default Re: ASRock P67 Extreme4 random hang on POST screen (code 98)

    I believe I have this fixed... at least for my system.

    Disable Legacy USB Support.

    By doing this, the system POSTed in record time, and then Windows failed to recognize my wireless mouse (Microsoft Blue Track something-or-other). My wireless keyboard (Logitech something-or-other) kept working like a champ, though. I tried going back into UEFI to try to fix the mouse but found that I couldn't because without Legacy USB enabled, no user input could be made prior to the OS loading.

    I ended up moving my mouse to a USB3 port and it proved to be exempt to whatever funkiness had caused the system to hang on POST code 98. Re-enabled Legacy USB Support and left the keyboard on a USB2 port so I can still access UEFI (albeit without mouse support). System boots reliably every time now!

    Hope this helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •