Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Asrock Extreme Gen3 wont get past UEFI screen




  1. #11
    Join Date
    Oct 2011
    Location
    Australia
    Posts
    2

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    I'm also having this problem on an Extreme4 Gen3 - my Logitech G510 USB keyboard is not recognised by the UEFI bios. It only starts working when I get to the Windows login screen.
    I switched it for an older Logitech G15 USB keyboard, and that works perfectly.

    Happy to test a beta BIOS.

  2. #12
    Join Date
    Oct 2011
    Location
    Russian Federation
    Posts
    1

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    Quote Originally Posted by ASRock TSD - Emily View Post
    Dear all,

    Please kindly provide your e-mail and model name for me, I will send BIOS to you for testing.

    Thanks!

    Have a nice day
    ASRock TSD
    Emily
    I have the same problems with G15 keyboard sometimes.

    PS:Do you know about vcore problems of extreme3 gen3?
    I'm happy to be a beta tester of new bios.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •